aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/eel')
-rw-r--r--x11-toolkits/eel/Makefile26
-rw-r--r--x11-toolkits/eel/distinfo2
-rw-r--r--x11-toolkits/eel/files/patch-Makefile.in11
-rw-r--r--x11-toolkits/eel/files/patch-eel_Makefile.in12
-rw-r--r--x11-toolkits/eel/files/patch-eel_eel-background.c29
-rw-r--r--x11-toolkits/eel/files/patch-eel_eel-editable-label.c13
-rw-r--r--x11-toolkits/eel/files/patch-eel_eel-stock-dialogs.c20
-rw-r--r--x11-toolkits/eel/pkg-descr7
-rw-r--r--x11-toolkits/eel/pkg-plist158
9 files changed, 0 insertions, 278 deletions
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
deleted file mode 100644
index f45eb5120a00..000000000000
--- a/x11-toolkits/eel/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# Created by: Ade Lovett <ade@FreeBSD.org>
-# $FreeBSD$
-# $MCom: ports/x11-toolkits/eel/Makefile,v 1.90 2010/09/28 09:15:49 kwm Exp $
-
-PORTNAME= eel
-PORTVERSION= 2.26.0
-PORTREVISION= 9
-CATEGORIES= x11-toolkits gnome
-MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Generally useful classes and extensions to GNOME
-
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_XORG= xrender
-GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomedesktop intlhack
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --enable-static
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-INSTALL_TARGET= install-strip
-
-.include <bsd.port.mk>
diff --git a/x11-toolkits/eel/distinfo b/x11-toolkits/eel/distinfo
deleted file mode 100644
index 2613b6e0160b..000000000000
--- a/x11-toolkits/eel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gnome2/eel-2.26.0.tar.bz2) = 11ad07d8d371f9165fab6cc5462f59cd253f9cc835d77a54330fecafe9c0a555
-SIZE (gnome2/eel-2.26.0.tar.bz2) = 596217
diff --git a/x11-toolkits/eel/files/patch-Makefile.in b/x11-toolkits/eel/files/patch-Makefile.in
deleted file mode 100644
index f58c574eb5fc..000000000000
--- a/x11-toolkits/eel/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Jan 16 12:53:35 2006
-+++ Makefile.in Mon Jan 16 12:54:04 2006
-@@ -239,7 +239,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- NULL =
--SUBDIRS = eel test po
-+SUBDIRS = eel po
- EXTRA_DIST = \
- COPYING.LIB \
- HACKING \
diff --git a/x11-toolkits/eel/files/patch-eel_Makefile.in b/x11-toolkits/eel/files/patch-eel_Makefile.in
deleted file mode 100644
index ec753e19eab4..000000000000
--- a/x11-toolkits/eel/files/patch-eel_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- eel/Makefile.in.orig 2010-09-28 11:12:01.000000000 +0000
-+++ eel/Makefile.in 2010-09-28 11:12:37.000000000 +0000
-@@ -290,9 +290,6 @@
- -DDATADIR=\""$(datadir)"\" \
- -DSOURCE_DATADIR=\""$(top_srcdir)/data"\" \
- -DGNOMELOCALEDIR=\""$(prefix)/${DATADIRNAME}/locale"\" \
-- -DG_DISABLE_DEPRECATED \
-- -DGDK_DISABLE_DEPRECATED \
-- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGMENU_I_KNOW_THIS_IS_UNSTABLE \
- $(NULL)
-
diff --git a/x11-toolkits/eel/files/patch-eel_eel-background.c b/x11-toolkits/eel/files/patch-eel_eel-background.c
deleted file mode 100644
index c7a21e7b8ad8..000000000000
--- a/x11-toolkits/eel/files/patch-eel_eel-background.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- eel/eel-background.c.orig 2009-03-02 11:21:55.000000000 -0500
-+++ eel/eel-background.c 2010-01-24 01:08:43.000000000 -0500
-@@ -368,7 +368,7 @@ eel_background_ensure_realized (EelBackg
-
- set_image_properties (background);
-
-- background->details->background_changes_with_size = gnome_bg_changes_with_size (background->details->bg);
-+ background->details->background_changes_with_size = gnome_bg_has_multiple_sizes (background->details->bg);
- background->details->background_pixmap = gnome_bg_create_pixmap (background->details->bg,
- window,
- entire_width, entire_height,
-@@ -747,7 +747,7 @@ eel_background_set_up_widget (EelBackgro
- }
-
- background->details->background_changes_with_size =
-- gnome_bg_changes_with_size (background->details->bg);
-+ gnome_bg_has_multiple_sizes (background->details->bg);
-
- if (background->details->is_desktop && !in_fade) {
- set_root_pixmap (background, window);
-@@ -1000,7 +1000,7 @@ eel_get_widget_background (GtkWidget *wi
- gboolean
- eel_background_is_dark (EelBackground *background)
- {
-- return gnome_bg_is_dark (background->details->bg);
-+ return gnome_bg_is_dark (background->details->bg, background->details->background_entire_width, background->details->background_entire_height);
- }
-
- /* handle dropped colors */
diff --git a/x11-toolkits/eel/files/patch-eel_eel-editable-label.c b/x11-toolkits/eel/files/patch-eel_eel-editable-label.c
deleted file mode 100644
index 042628e4b6f9..000000000000
--- a/x11-toolkits/eel/files/patch-eel_eel-editable-label.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- eel/eel-editable-label.c.orig Mon Mar 21 06:20:09 2005
-+++ eel/eel-editable-label.c Mon Mar 21 06:20:12 2005
-@@ -3998,7 +3998,10 @@
- static gboolean
- eel_editable_label_accessible_idle_notify_insert (gpointer data)
- {
-+ GDK_THREADS_ENTER ();
- eel_editable_label_accessible_notify_insert (data);
-+ GDK_THREADS_LEAVE ();
-+
- return FALSE;
- }
-
diff --git a/x11-toolkits/eel/files/patch-eel_eel-stock-dialogs.c b/x11-toolkits/eel/files/patch-eel_eel-stock-dialogs.c
deleted file mode 100644
index 4a0ce9c74ecc..000000000000
--- a/x11-toolkits/eel/files/patch-eel_eel-stock-dialogs.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- eel/eel-stock-dialogs.c.orig 2008-10-07 11:34:27.000000000 +0200
-+++ eel/eel-stock-dialogs.c 2009-02-22 16:33:40.000000000 +0100
-@@ -96,6 +96,8 @@ timed_wait_delayed_close_timeout_callbac
- {
- guint handler_id;
-
-+ GDK_THREADS_ENTER ();
-+
- handler_id = GPOINTER_TO_UINT (g_object_get_data (G_OBJECT (callback_data),
- "eel-stock-dialogs/delayed_close_handler_timeout_id"));
-
-@@ -105,6 +107,8 @@ timed_wait_delayed_close_timeout_callbac
-
- gtk_object_destroy (GTK_OBJECT (callback_data));
-
-+ GDK_THREADS_LEAVE ();
-+
- return FALSE;
- }
-
diff --git a/x11-toolkits/eel/pkg-descr b/x11-toolkits/eel/pkg-descr
deleted file mode 100644
index 4b91eb9d0da3..000000000000
--- a/x11-toolkits/eel/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-The eel library contains a number of useful classes and functions which
-extend glib, gtk, gnome-libs, and other widely-used GNOME platform libraries.
-
-Almost all of the eel library was previously part of Nautilus, but is now
-a separate package so it can be used by other applications.
-
-WWW: http://www.gnome.org/
diff --git a/x11-toolkits/eel/pkg-plist b/x11-toolkits/eel/pkg-plist
deleted file mode 100644
index db693a80b84c..000000000000
--- a/x11-toolkits/eel/pkg-plist
+++ /dev/null
@@ -1,158 +0,0 @@
-include/eel-2/eel/eel-accessibility.h
-include/eel-2/eel/eel-alert-dialog.h
-include/eel-2/eel/eel-art-extensions.h
-include/eel-2/eel/eel-art-gtk-extensions.h
-include/eel-2/eel/eel-background-box.h
-include/eel-2/eel/eel-background.h
-include/eel-2/eel/eel-canvas-rect-ellipse.h
-include/eel-2/eel/eel-canvas-util.h
-include/eel-2/eel/eel-canvas.h
-include/eel-2/eel/eel-debug-drawing.h
-include/eel-2/eel/eel-debug.h
-include/eel-2/eel/eel-editable-label.h
-include/eel-2/eel/eel-enumeration.h
-include/eel-2/eel/eel-features.h
-include/eel-2/eel/eel-gconf-extensions.h
-include/eel-2/eel/eel-gdk-extensions.h
-include/eel-2/eel/eel-gdk-pixbuf-extensions.h
-include/eel-2/eel/eel-glib-extensions.h
-include/eel-2/eel/eel-gnome-extensions.h
-include/eel-2/eel/eel-graphic-effects.h
-include/eel-2/eel/eel-gtk-container.h
-include/eel-2/eel/eel-gtk-extensions.h
-include/eel-2/eel/eel-gtk-macros.h
-include/eel-2/eel/eel-i18n.h
-include/eel-2/eel/eel-image-table.h
-include/eel-2/eel/eel-labeled-image.h
-include/eel-2/eel/eel-marshal.h
-include/eel-2/eel/eel-pango-extensions.h
-include/eel-2/eel/eel-preferences.h
-include/eel-2/eel/eel-self-checks.h
-include/eel-2/eel/eel-stock-dialogs.h
-include/eel-2/eel/eel-string.h
-include/eel-2/eel/eel-type-builtins.h
-include/eel-2/eel/eel-types.h
-include/eel-2/eel/eel-vfs-extensions.h
-include/eel-2/eel/eel-wrap-table.h
-include/eel-2/eel/eel-xml-extensions.h
-include/eel-2/eel/eel.h
-lib/libeel-2.a
-lib/libeel-2.la
-lib/libeel-2.so
-lib/libeel-2.so.2
-lib/libeel-2.so.2.26.0
-libdata/pkgconfig/eel-2.0.pc
-share/locale/am/LC_MESSAGES/eel-2.0.mo
-share/locale/ang/LC_MESSAGES/eel-2.0.mo
-share/locale/ar/LC_MESSAGES/eel-2.0.mo
-share/locale/as/LC_MESSAGES/eel-2.0.mo
-share/locale/az/LC_MESSAGES/eel-2.0.mo
-share/locale/be/LC_MESSAGES/eel-2.0.mo
-share/locale/bg/LC_MESSAGES/eel-2.0.mo
-share/locale/bn/LC_MESSAGES/eel-2.0.mo
-share/locale/bn_IN/LC_MESSAGES/eel-2.0.mo
-share/locale/br/LC_MESSAGES/eel-2.0.mo
-share/locale/bs/LC_MESSAGES/eel-2.0.mo
-share/locale/ca/LC_MESSAGES/eel-2.0.mo
-share/locale/cs/LC_MESSAGES/eel-2.0.mo
-share/locale/cy/LC_MESSAGES/eel-2.0.mo
-share/locale/da/LC_MESSAGES/eel-2.0.mo
-share/locale/de/LC_MESSAGES/eel-2.0.mo
-share/locale/dz/LC_MESSAGES/eel-2.0.mo
-share/locale/el/LC_MESSAGES/eel-2.0.mo
-share/locale/en_CA/LC_MESSAGES/eel-2.0.mo
-share/locale/en_GB/LC_MESSAGES/eel-2.0.mo
-share/locale/es/LC_MESSAGES/eel-2.0.mo
-share/locale/et/LC_MESSAGES/eel-2.0.mo
-share/locale/eu/LC_MESSAGES/eel-2.0.mo
-share/locale/fa/LC_MESSAGES/eel-2.0.mo
-share/locale/fi/LC_MESSAGES/eel-2.0.mo
-share/locale/fr/LC_MESSAGES/eel-2.0.mo
-share/locale/ga/LC_MESSAGES/eel-2.0.mo
-share/locale/gl/LC_MESSAGES/eel-2.0.mo
-share/locale/gu/LC_MESSAGES/eel-2.0.mo
-share/locale/he/LC_MESSAGES/eel-2.0.mo
-share/locale/hi/LC_MESSAGES/eel-2.0.mo
-share/locale/hr/LC_MESSAGES/eel-2.0.mo
-share/locale/hu/LC_MESSAGES/eel-2.0.mo
-share/locale/id/LC_MESSAGES/eel-2.0.mo
-share/locale/is/LC_MESSAGES/eel-2.0.mo
-share/locale/it/LC_MESSAGES/eel-2.0.mo
-share/locale/ja/LC_MESSAGES/eel-2.0.mo
-share/locale/ka/LC_MESSAGES/eel-2.0.mo
-share/locale/kn/LC_MESSAGES/eel-2.0.mo
-share/locale/ko/LC_MESSAGES/eel-2.0.mo
-share/locale/ku/LC_MESSAGES/eel-2.0.mo
-share/locale/ky/LC_MESSAGES/eel-2.0.mo
-share/locale/li/LC_MESSAGES/eel-2.0.mo
-share/locale/lt/LC_MESSAGES/eel-2.0.mo
-share/locale/lv/LC_MESSAGES/eel-2.0.mo
-share/locale/mk/LC_MESSAGES/eel-2.0.mo
-share/locale/ml/LC_MESSAGES/eel-2.0.mo
-share/locale/mn/LC_MESSAGES/eel-2.0.mo
-share/locale/mr/LC_MESSAGES/eel-2.0.mo
-share/locale/ms/LC_MESSAGES/eel-2.0.mo
-share/locale/nb/LC_MESSAGES/eel-2.0.mo
-share/locale/ne/LC_MESSAGES/eel-2.0.mo
-share/locale/nl/LC_MESSAGES/eel-2.0.mo
-share/locale/nn/LC_MESSAGES/eel-2.0.mo
-share/locale/oc/LC_MESSAGES/eel-2.0.mo
-share/locale/or/LC_MESSAGES/eel-2.0.mo
-share/locale/pa/LC_MESSAGES/eel-2.0.mo
-share/locale/pl/LC_MESSAGES/eel-2.0.mo
-share/locale/ps/LC_MESSAGES/eel-2.0.mo
-share/locale/pt/LC_MESSAGES/eel-2.0.mo
-share/locale/pt_BR/LC_MESSAGES/eel-2.0.mo
-share/locale/ro/LC_MESSAGES/eel-2.0.mo
-share/locale/ru/LC_MESSAGES/eel-2.0.mo
-share/locale/rw/LC_MESSAGES/eel-2.0.mo
-share/locale/si/LC_MESSAGES/eel-2.0.mo
-share/locale/sk/LC_MESSAGES/eel-2.0.mo
-share/locale/sl/LC_MESSAGES/eel-2.0.mo
-share/locale/sq/LC_MESSAGES/eel-2.0.mo
-share/locale/sr/LC_MESSAGES/eel-2.0.mo
-share/locale/sr@latin/LC_MESSAGES/eel-2.0.mo
-share/locale/sv/LC_MESSAGES/eel-2.0.mo
-share/locale/ta/LC_MESSAGES/eel-2.0.mo
-share/locale/th/LC_MESSAGES/eel-2.0.mo
-share/locale/tr/LC_MESSAGES/eel-2.0.mo
-share/locale/ug/LC_MESSAGES/eel-2.0.mo
-share/locale/uk/LC_MESSAGES/eel-2.0.mo
-share/locale/vi/LC_MESSAGES/eel-2.0.mo
-share/locale/wa/LC_MESSAGES/eel-2.0.mo
-share/locale/xh/LC_MESSAGES/eel-2.0.mo
-share/locale/zh_CN/LC_MESSAGES/eel-2.0.mo
-share/locale/zh_HK/LC_MESSAGES/eel-2.0.mo
-share/locale/zh_TW/LC_MESSAGES/eel-2.0.mo
-@dirrm include/eel-2/eel
-@dirrm include/eel-2
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/ky/LC_MESSAGES
-@dirrmtry share/locale/ky
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as
-@dirrmtry share/locale/ang/LC_MESSAGES
-@dirrmtry share/locale/ang