aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 60c35bc80daf..0b6715615551 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -19,23 +19,21 @@ DISTNAME= ${PORTNAME}-${VERSION}-source
MAINTAINER?= demon@FreeBSD.org
.if defined(WITH_XUNICODE)
-PATCH_VERSION= 20000625
+PATCH_VERSION= 20010114
_PORTVERSION+= ${VERSION}.${PATCH_VERSION}
PKGNAMESUFFIX= -xunicode
PATCH_SITES= http://www.ab.wakwak.com/~tino/jatk/fltk/
-PATCHFILES= ${PORTNAME}-${VERSION}${PKGNAMESUFFIX}-${PATCH_VERSION}.diff.gz
+PATCHFILES= ${PORTNAME}-${VERSION}${PKGNAMESUFFIX}-${PATCH_VERSION}.diff
PATCH_DIST_STRIP= -p1
-EXTRA_PATCHES= ${PATCHDIR}/xunicode.patch-*
-
-BUILD_DEPENDS= ${X11BASE}/lib/libxunicode.a:${PORTSDIR}/converters/xunicode
+BUILD_DEPENDS= ${X11BASE}/include/xunicode/xunicode.h:${PORTSDIR}/converters/xunicode
.else
_PORTVERSION+= ${VERSION}
.endif
-VERSION= 1.0.9
+VERSION= 1.0.10
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -45,6 +43,11 @@ USE_X_PREFIX= yes
USE_MESA= yes
MAN1= fluid.1
+.if defined(WITH_XUNICODE)
+post-extract:
+ cd ${WRKSRC} && ${LN} -s ${X11BASE}/include/xunicode
+.endif
+
post-install:
@ ${INSTALL_MAN} ${WRKSRC}/documentation/fluid.1 \
${PREFIX}/man/man1