aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index eacfe0294ca0..07ea0022d86a 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -34,7 +34,8 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shared --enable-xft
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+# configure ignores ${CXX} and keeps on linking C++ code with ${CC}
+CONFIGURE_ENV+= CC="${CXX}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}
USE_X_PREFIX= yes