aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox16
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fox16')
-rw-r--r--x11-toolkits/fox16/Makefile156
-rw-r--r--x11-toolkits/fox16/distinfo3
-rw-r--r--x11-toolkits/fox16/files/patch-configure11
-rw-r--r--x11-toolkits/fox16/files/patch-src_FXFile.cpp29
-rw-r--r--x11-toolkits/fox16/files/patch-utils_Makefile.in11
-rw-r--r--x11-toolkits/fox16/pkg-descr11
-rw-r--r--x11-toolkits/fox16/pkg-plist370
7 files changed, 0 insertions, 591 deletions
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
deleted file mode 100644
index 930ea0cf02d5..000000000000
--- a/x11-toolkits/fox16/Makefile
+++ /dev/null
@@ -1,156 +0,0 @@
-# New ports collection makefile for: fox
-# Date created: 28 Jul 2005
-# Whom: Alexander Novitsky <alecn2002@yandex.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= fox
-PORTVERSION= ${MAJORVER}.${SHVER}
-PORTREVISION= 1
-CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
- ftp://ftp.fox-toolkit.org/pub/ \
- http://fresh.t-systems-sfr.com/unix/src/misc/
-
-MAINTAINER?= alecn2002@yandex.ru
-COMMENT= Fast and extensive C++ GUI toolkit -- ver.1.2
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- Xft.2:${PORTSDIR}/x11-fonts/libXft
-
-CONFLICTS= fox-1.0.* fox-1.4.*
-
-LATEST_LINK= fox12
-
-MAJORVER= 1.2
-SHVER= 16
-PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
-
-USE_GNOME= lthack
-USE_GL= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
-INSTALLS_SHLIB= yes
-
-MAN1= shutterbug.1 reswrap.1
-
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-
-.include <bsd.port.pre.mk>
-
-##
-## Additional Options
-##
-#
-.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --with-xft=no
-.else
-CONFIGURE_ARGS+= --with-xft=yes
-CPPFLAGS+= `freetype-config --cflags`
-LDFLAGS+= `freetype-config --libs`
-.endif
-#
-.if defined(WITHOUT_SHM)
-CONFIGURE_ARGS+= --with-xshm=no
-.else
-CONFIGURE_ARGS+= --with-xshm=yes
-.endif
-#
-.if defined(WITH_CUPS)
-CONFIGURE_ARGS+= --enable-cups
-.else
-CONFIGURE_ARGS+= --disable-cups
-.endif
-#
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
-.else
-CONFIGURE_ARGS+= --enable-release
-.endif
-#
-.if defined(WITH_FOX_APPLICATIONS)
-MAN1+= PathFinder.1 adie.1 calculator.1
-PLIST_SUB+= APPS=""
-.else
-PLIST_SUB+= APPS="@comment "
-.endif
-#
-.if defined(WITH_OPTIMIZED_CXXFLAGS)
-# turn distribution-recommended optimization flags back on
-CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
-.endif
-#
-.if defined(WITH_PROFILING)
-CONFIGURE_ARGS+= --with-profiling=gprof
-.endif
-#
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= DOC=
-.else
-MAKE_ARGS+= DOC=doc
-.endif
-
-post-patch:
-# CXXFLAGS safeness
- @${REINPLACE_CMD} -E -e \
- 's|-O2|${CXXFLAGS}|g ; \
- s|-lc_r|${PTHREAD_LIBS}|g ; \
- s|FOX_INTERFACE_VERSION=0|FOX_INTERFACE_VERSION=${SHVER}|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-# doc prefix safeness
- @${REINPLACE_CMD} -E -e \
- 's|^(htmldir).*$$|\1=${DOCSDIR}/html|' \
- ${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -E -e \
- 's|^(artdir).*$$|\1=${DOCSDIR}/html|' \
- ${WRKSRC}/doc/art/Makefile.in
- @${REINPLACE_CMD} -E -e \
- 's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
- ${WRKSRC}/doc/screenshots/Makefile.in
-.if !defined(WITH_FOX_APPLICATIONS)
- @${REINPLACE_CMD} -E -e \
- 's,^(SUBDIRS.*)adie,\1,; \
- s,^(SUBDIRS.*)pathfinder,\1,; \
- s,^(SUBDIRS.*)calculator,\1,' \
- ${WRKSRC}/Makefile.in
-.endif
-
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable additional compilation optimizations'
- @${ECHO_MSG} 'by defining WITH_OPTIMIZED_CXXFLAGS'
-.endif
-.if !defined(WITH_CUPS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable CUPS support by defining WITH_CUPS'
-.endif
-.if !defined(WITH_DEBUG)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build DEBUG support by defining WITH_DEBUG'
-.endif
-.if !defined(WITH_FOX_APPLICATIONS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can install FOX sample applications by defining WITH_FOX_APPLICATIONS"
-.endif
-.if !defined(WITH_PROFILING)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build PROFILING support by defining WITH_PROFILING'
-.endif
-.if !defined(WITHOUT_SHM)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
-.endif
-.if !defined(WITHOUT_XFT)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Xft support by defining WITHOUT_XFT'
-.endif
- @${ECHO_MSG}
-
-.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox16/distinfo b/x11-toolkits/fox16/distinfo
deleted file mode 100644
index 1fb4cddd6708..000000000000
--- a/x11-toolkits/fox16/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (fox-1.2.16.tar.gz) = f898da23fe7678faf5380224fbf0b3c3
-SHA256 (fox-1.2.16.tar.gz) = 8a08e30064d4a7bae74f7896d8e097449359e846fed6f732a5139f1e5dc498f0
-SIZE (fox-1.2.16.tar.gz) = 3896051
diff --git a/x11-toolkits/fox16/files/patch-configure b/x11-toolkits/fox16/files/patch-configure
deleted file mode 100644
index cd0f6671becd..000000000000
--- a/x11-toolkits/fox16/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Feb 4 18:33:38 2003
-+++ configure Tue Feb 4 18:34:51 2003
-@@ -7498,7 +7498,7 @@
- if test "x$enable_release" = "xyes" ; then
- CXXFLAGS="${CXXFLAGS} -O2 -DNDEBUG"
- if test "${GXX}" = "yes" ; then
--CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
-+CXXFLAGS="${CXXFLAGS} -Wuninitialized"
- fi
- fi
-
diff --git a/x11-toolkits/fox16/files/patch-src_FXFile.cpp b/x11-toolkits/fox16/files/patch-src_FXFile.cpp
deleted file mode 100644
index 1edb77d8c85f..000000000000
--- a/x11-toolkits/fox16/files/patch-src_FXFile.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
-+++ src/FXFile.cpp Sat May 22 13:13:48 2004
-@@ -159,7 +159,7 @@
- // Get home directory for a given user
- FXString FXFile::getUserDirectory(const FXString& user){
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- struct passwd pwdresult,*pwd;
- char buffer[1024];
- if(user.empty()){
-@@ -1032,7 +1032,7 @@
- FXString FXFile::owner(FXuint uid){
- FXchar result[64];
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- struct passwd pwdresult,*pwd;
- char buffer[1024];
- if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
-@@ -1050,7 +1050,7 @@
- FXString FXFile::group(FXuint gid){
- FXchar result[64];
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- ::group grpresult;
- ::group *grp;
- char buffer[1024];
diff --git a/x11-toolkits/fox16/files/patch-utils_Makefile.in b/x11-toolkits/fox16/files/patch-utils_Makefile.in
deleted file mode 100644
index ea447c9dbea3..000000000000
--- a/x11-toolkits/fox16/files/patch-utils_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- utils/Makefile.in.orig Sun Aug 15 11:30:45 2004
-+++ utils/Makefile.in Sun Aug 15 11:30:55 2004
-@@ -106,7 +106,7 @@
- DEFS = @DEFS@ -I. -I$(srcdir)
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ -lX11 -lXext
- X_CFLAGS = @X_CFLAGS@
- X_LIBS = @X_LIBS@
- X_EXTRA_LIBS = @X_EXTRA_LIBS@
diff --git a/x11-toolkits/fox16/pkg-descr b/x11-toolkits/fox16/pkg-descr
deleted file mode 100644
index 0ce2e12c437e..000000000000
--- a/x11-toolkits/fox16/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-FOX is a C++ GUI toolkit that is supposed to
-allow programmers to write a program once, and
-compile anywhere (or so the website says, it sounds
-like Java to me). FOX is a very flexible library,
-it has all sorts of functions and options, and is
-supposed to be fairly fast.
-
-WWW: http://www.fox-toolkit.org/fox.html
-Author: Jeroen van der Zijp <jvz@cfdrc.com>
-
---Will <andrews@technologist.com>
diff --git a/x11-toolkits/fox16/pkg-plist b/x11-toolkits/fox16/pkg-plist
deleted file mode 100644
index 4fbc2eed8ba0..000000000000
--- a/x11-toolkits/fox16/pkg-plist
+++ /dev/null
@@ -1,370 +0,0 @@
-%%APPS%%bin/PathFinder
-%%APPS%%bin/adie
-%%APPS%%bin/calculator
-bin/reswrap
-bin/shutterbug
-bin/fox-config
-include/fox-%%MAJORVER%%/FX4Splitter.h
-include/fox-%%MAJORVER%%/FXAccelTable.h
-include/fox-%%MAJORVER%%/FXApp.h
-include/fox-%%MAJORVER%%/FXArray.h
-include/fox-%%MAJORVER%%/FXArrowButton.h
-include/fox-%%MAJORVER%%/FXBMPIcon.h
-include/fox-%%MAJORVER%%/FXBMPImage.h
-include/fox-%%MAJORVER%%/FXBZStream.h
-include/fox-%%MAJORVER%%/FXBitmap.h
-include/fox-%%MAJORVER%%/FXBitmapFrame.h
-include/fox-%%MAJORVER%%/FXBitmapView.h
-include/fox-%%MAJORVER%%/FXButton.h
-include/fox-%%MAJORVER%%/FXCURCursor.h
-include/fox-%%MAJORVER%%/FXCanvas.h
-include/fox-%%MAJORVER%%/FXCharset.h
-include/fox-%%MAJORVER%%/FXCheckButton.h
-include/fox-%%MAJORVER%%/FXColorBar.h
-include/fox-%%MAJORVER%%/FXColorDialog.h
-include/fox-%%MAJORVER%%/FXColorSelector.h
-include/fox-%%MAJORVER%%/FXColorWell.h
-include/fox-%%MAJORVER%%/FXColorWheel.h
-include/fox-%%MAJORVER%%/FXComboBox.h
-include/fox-%%MAJORVER%%/FXComposite.h
-include/fox-%%MAJORVER%%/FXCursor.h
-include/fox-%%MAJORVER%%/FXDC.h
-include/fox-%%MAJORVER%%/FXDCPrint.h
-include/fox-%%MAJORVER%%/FXDCWindow.h
-include/fox-%%MAJORVER%%/FXDLL.h
-include/fox-%%MAJORVER%%/FXDataTarget.h
-include/fox-%%MAJORVER%%/FXDebugTarget.h
-include/fox-%%MAJORVER%%/FXDelegator.h
-include/fox-%%MAJORVER%%/FXDial.h
-include/fox-%%MAJORVER%%/FXDialogBox.h
-include/fox-%%MAJORVER%%/FXDict.h
-include/fox-%%MAJORVER%%/FXDirBox.h
-include/fox-%%MAJORVER%%/FXDirDialog.h
-include/fox-%%MAJORVER%%/FXDirList.h
-include/fox-%%MAJORVER%%/FXDirSelector.h
-include/fox-%%MAJORVER%%/FXDocument.h
-include/fox-%%MAJORVER%%/FXDragCorner.h
-include/fox-%%MAJORVER%%/FXDrawable.h
-include/fox-%%MAJORVER%%/FXDriveBox.h
-include/fox-%%MAJORVER%%/FXElement.h
-include/fox-%%MAJORVER%%/FXException.h
-include/fox-%%MAJORVER%%/FXFile.h
-include/fox-%%MAJORVER%%/FXFileDialog.h
-include/fox-%%MAJORVER%%/FXFileDict.h
-include/fox-%%MAJORVER%%/FXFileList.h
-include/fox-%%MAJORVER%%/FXFileSelector.h
-include/fox-%%MAJORVER%%/FXFileStream.h
-include/fox-%%MAJORVER%%/FXFoldingList.h
-include/fox-%%MAJORVER%%/FXFont.h
-include/fox-%%MAJORVER%%/FXFontDialog.h
-include/fox-%%MAJORVER%%/FXFontSelector.h
-include/fox-%%MAJORVER%%/FXFrame.h
-include/fox-%%MAJORVER%%/FXGIFCursor.h
-include/fox-%%MAJORVER%%/FXGIFIcon.h
-include/fox-%%MAJORVER%%/FXGIFImage.h
-include/fox-%%MAJORVER%%/FXGLCanvas.h
-include/fox-%%MAJORVER%%/FXGLCone.h
-include/fox-%%MAJORVER%%/FXGLContext.h
-include/fox-%%MAJORVER%%/FXGLCube.h
-include/fox-%%MAJORVER%%/FXGLCylinder.h
-include/fox-%%MAJORVER%%/FXGLObject.h
-include/fox-%%MAJORVER%%/FXGLShape.h
-include/fox-%%MAJORVER%%/FXGLSphere.h
-include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
-include/fox-%%MAJORVER%%/FXGLViewer.h
-include/fox-%%MAJORVER%%/FXGLVisual.h
-include/fox-%%MAJORVER%%/FXGZStream.h
-include/fox-%%MAJORVER%%/FXGradientBar.h
-include/fox-%%MAJORVER%%/FXGroupBox.h
-include/fox-%%MAJORVER%%/FXHash.h
-include/fox-%%MAJORVER%%/FXHeader.h
-include/fox-%%MAJORVER%%/FXHorizontalFrame.h
-include/fox-%%MAJORVER%%/FXICOIcon.h
-include/fox-%%MAJORVER%%/FXICOImage.h
-include/fox-%%MAJORVER%%/FXIcon.h
-include/fox-%%MAJORVER%%/FXIconList.h
-include/fox-%%MAJORVER%%/FXId.h
-include/fox-%%MAJORVER%%/FXImage.h
-include/fox-%%MAJORVER%%/FXImageFrame.h
-include/fox-%%MAJORVER%%/FXImageView.h
-include/fox-%%MAJORVER%%/FXInputDialog.h
-include/fox-%%MAJORVER%%/FXJPGIcon.h
-include/fox-%%MAJORVER%%/FXJPGImage.h
-include/fox-%%MAJORVER%%/FXLabel.h
-include/fox-%%MAJORVER%%/FXList.h
-include/fox-%%MAJORVER%%/FXListBox.h
-include/fox-%%MAJORVER%%/FXMDIButton.h
-include/fox-%%MAJORVER%%/FXMDIChild.h
-include/fox-%%MAJORVER%%/FXMDIClient.h
-include/fox-%%MAJORVER%%/FXMainWindow.h
-include/fox-%%MAJORVER%%/FXMat3d.h
-include/fox-%%MAJORVER%%/FXMat3f.h
-include/fox-%%MAJORVER%%/FXMat4d.h
-include/fox-%%MAJORVER%%/FXMat4f.h
-include/fox-%%MAJORVER%%/FXMatrix.h
-include/fox-%%MAJORVER%%/FXMemoryStream.h
-include/fox-%%MAJORVER%%/FXMenuBar.h
-include/fox-%%MAJORVER%%/FXMenuButton.h
-include/fox-%%MAJORVER%%/FXMenuCaption.h
-include/fox-%%MAJORVER%%/FXMenuCascade.h
-include/fox-%%MAJORVER%%/FXMenuCheck.h
-include/fox-%%MAJORVER%%/FXMenuCommand.h
-include/fox-%%MAJORVER%%/FXMenuPane.h
-include/fox-%%MAJORVER%%/FXMenuRadio.h
-include/fox-%%MAJORVER%%/FXMenuSeparator.h
-include/fox-%%MAJORVER%%/FXMenuTitle.h
-include/fox-%%MAJORVER%%/FXMessageBox.h
-include/fox-%%MAJORVER%%/FXObject.h
-include/fox-%%MAJORVER%%/FXObjectList.h
-include/fox-%%MAJORVER%%/FXOptionMenu.h
-include/fox-%%MAJORVER%%/FXPCXIcon.h
-include/fox-%%MAJORVER%%/FXPCXImage.h
-include/fox-%%MAJORVER%%/FXPNGIcon.h
-include/fox-%%MAJORVER%%/FXPNGImage.h
-include/fox-%%MAJORVER%%/FXPPMIcon.h
-include/fox-%%MAJORVER%%/FXPPMImage.h
-include/fox-%%MAJORVER%%/FXPacker.h
-include/fox-%%MAJORVER%%/FXPicker.h
-include/fox-%%MAJORVER%%/FXPoint.h
-include/fox-%%MAJORVER%%/FXPopup.h
-include/fox-%%MAJORVER%%/FXPrintDialog.h
-include/fox-%%MAJORVER%%/FXProgressBar.h
-include/fox-%%MAJORVER%%/FXProgressDialog.h
-include/fox-%%MAJORVER%%/FXQuatd.h
-include/fox-%%MAJORVER%%/FXQuatf.h
-include/fox-%%MAJORVER%%/FXRGBIcon.h
-include/fox-%%MAJORVER%%/FXRGBImage.h
-include/fox-%%MAJORVER%%/FXRadioButton.h
-include/fox-%%MAJORVER%%/FXRanged.h
-include/fox-%%MAJORVER%%/FXRangef.h
-include/fox-%%MAJORVER%%/FXRealSlider.h
-include/fox-%%MAJORVER%%/FXRealSpinner.h
-include/fox-%%MAJORVER%%/FXRecentFiles.h
-include/fox-%%MAJORVER%%/FXRectangle.h
-include/fox-%%MAJORVER%%/FXRegion.h
-include/fox-%%MAJORVER%%/FXRegistry.h
-include/fox-%%MAJORVER%%/FXReplaceDialog.h
-include/fox-%%MAJORVER%%/FXRex.h
-include/fox-%%MAJORVER%%/FXRootWindow.h
-include/fox-%%MAJORVER%%/FXRuler.h
-include/fox-%%MAJORVER%%/FXScrollArea.h
-include/fox-%%MAJORVER%%/FXScrollBar.h
-include/fox-%%MAJORVER%%/FXScrollPane.h
-include/fox-%%MAJORVER%%/FXScrollWindow.h
-include/fox-%%MAJORVER%%/FXSearchDialog.h
-include/fox-%%MAJORVER%%/FXSeparator.h
-include/fox-%%MAJORVER%%/FXSettings.h
-include/fox-%%MAJORVER%%/FXShell.h
-include/fox-%%MAJORVER%%/FXShutter.h
-include/fox-%%MAJORVER%%/FXSize.h
-include/fox-%%MAJORVER%%/FXSlider.h
-include/fox-%%MAJORVER%%/FXSphered.h
-include/fox-%%MAJORVER%%/FXSpheref.h
-include/fox-%%MAJORVER%%/FXSpinner.h
-include/fox-%%MAJORVER%%/FXSplitter.h
-include/fox-%%MAJORVER%%/FXSpring.h
-include/fox-%%MAJORVER%%/FXStatusBar.h
-include/fox-%%MAJORVER%%/FXStatusLine.h
-include/fox-%%MAJORVER%%/FXStream.h
-include/fox-%%MAJORVER%%/FXString.h
-include/fox-%%MAJORVER%%/FXStringDict.h
-include/fox-%%MAJORVER%%/FXSwitcher.h
-include/fox-%%MAJORVER%%/FXTGAIcon.h
-include/fox-%%MAJORVER%%/FXTGAImage.h
-include/fox-%%MAJORVER%%/FXTIFIcon.h
-include/fox-%%MAJORVER%%/FXTIFImage.h
-include/fox-%%MAJORVER%%/FXTabBar.h
-include/fox-%%MAJORVER%%/FXTabBook.h
-include/fox-%%MAJORVER%%/FXTabItem.h
-include/fox-%%MAJORVER%%/FXTable.h
-include/fox-%%MAJORVER%%/FXText.h
-include/fox-%%MAJORVER%%/FXTextCodec.h
-include/fox-%%MAJORVER%%/FXTextField.h
-include/fox-%%MAJORVER%%/FXThread.h
-include/fox-%%MAJORVER%%/FXToggleButton.h
-include/fox-%%MAJORVER%%/FXToolBar.h
-include/fox-%%MAJORVER%%/FXToolBarGrip.h
-include/fox-%%MAJORVER%%/FXToolBarShell.h
-include/fox-%%MAJORVER%%/FXToolBarTab.h
-include/fox-%%MAJORVER%%/FXToolTip.h
-include/fox-%%MAJORVER%%/FXTopWindow.h
-include/fox-%%MAJORVER%%/FXTreeList.h
-include/fox-%%MAJORVER%%/FXTreeListBox.h
-include/fox-%%MAJORVER%%/FXTriStateButton.h
-include/fox-%%MAJORVER%%/FXURL.h
-include/fox-%%MAJORVER%%/FXUTF16Codec.h
-include/fox-%%MAJORVER%%/FXUTF32Codec.h
-include/fox-%%MAJORVER%%/FXUTF8Codec.h
-include/fox-%%MAJORVER%%/FXUndoList.h
-include/fox-%%MAJORVER%%/FXVec2d.h
-include/fox-%%MAJORVER%%/FXVec2f.h
-include/fox-%%MAJORVER%%/FXVec3d.h
-include/fox-%%MAJORVER%%/FXVec3f.h
-include/fox-%%MAJORVER%%/FXVec4d.h
-include/fox-%%MAJORVER%%/FXVec4f.h
-include/fox-%%MAJORVER%%/FXVerticalFrame.h
-include/fox-%%MAJORVER%%/FXVisual.h
-include/fox-%%MAJORVER%%/FXWString.h
-include/fox-%%MAJORVER%%/FXWindow.h
-include/fox-%%MAJORVER%%/FXWizard.h
-include/fox-%%MAJORVER%%/FXXBMIcon.h
-include/fox-%%MAJORVER%%/FXXBMImage.h
-include/fox-%%MAJORVER%%/FXXPMIcon.h
-include/fox-%%MAJORVER%%/FXXPMImage.h
-include/fox-%%MAJORVER%%/chart/FXChart.h
-include/fox-%%MAJORVER%%/fx.h
-include/fox-%%MAJORVER%%/fx3d.h
-include/fox-%%MAJORVER%%/fxdefs.h
-include/fox-%%MAJORVER%%/fxkeys.h
-include/fox-%%MAJORVER%%/fxver.h
-include/fox-%%MAJORVER%%/xincs.h
-lib/libCHART-%%MAJORVER%%.a
-lib/libCHART-%%MAJORVER%%.la
-lib/libCHART-%%MAJORVER%%.so
-lib/libCHART-%%MAJORVER%%.so.%%SHVER%%
-lib/libFOX-%%MAJORVER%%.a
-lib/libFOX-%%MAJORVER%%.la
-lib/libFOX-%%MAJORVER%%.so
-lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
-%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/adie.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/adie.html
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_colors.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_edit.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_font.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/adie_sty.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/analysisview.png
-%%PORTDOCS%%%%DOCSDIR%%/html/app.html
-%%PORTDOCS%%%%DOCSDIR%%/html/aqx_linux_visualizacao_peq.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot.png
-%%PORTDOCS%%%%DOCSDIR%%/html/arithmedrill-screenshot_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/bigpenguin.png
-%%PORTDOCS%%%%DOCSDIR%%/html/boskalisday.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/boskalisnite.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/calc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/clipboard.html
-%%PORTDOCS%%%%DOCSDIR%%/html/clview_icon.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/colordialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/cometassay.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/consulting.html
-%%PORTDOCS%%%%DOCSDIR%%/html/contact.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/datatarget.html
-%%PORTDOCS%%%%DOCSDIR%%/html/dirdialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit1.png
-%%PORTDOCS%%%%DOCSDIR%%/html/dlgedit2.png
-%%PORTDOCS%%%%DOCSDIR%%/html/doc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/download.html
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.cfg
-%%PORTDOCS%%%%DOCSDIR%%/html/draganddrop.html
-%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen.png
-%%PORTDOCS%%%%DOCSDIR%%/html/emso_screen_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fifthplanet.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/filedialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/filefuncs.html
-%%PORTDOCS%%%%DOCSDIR%%/html/filter.pl
-%%PORTDOCS%%%%DOCSDIR%%/html/focus.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fontdialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/fonts.html
-%%PORTDOCS%%%%DOCSDIR%%/html/footer.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreword.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fox.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/fox.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc_prefdialog_01_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc_prefdialog_02_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxcalc_prefdialog_03_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxlogo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxlogo.png
-%%PORTDOCS%%%%DOCSDIR%%/html/foxlogo_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/foxstart.png
-%%PORTDOCS%%%%DOCSDIR%%/html/freespeach.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/glview.png
-%%PORTDOCS%%%%DOCSDIR%%/html/goals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/goggles.png
-%%PORTDOCS%%%%DOCSDIR%%/html/guiupdate.html
-%%PORTDOCS%%%%DOCSDIR%%/html/header.html
-%%PORTDOCS%%%%DOCSDIR%%/html/home.html
-%%PORTDOCS%%%%DOCSDIR%%/html/icons.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ill.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/ilr.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/imagedebugger.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/innernerd.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/install.html
-%%PORTDOCS%%%%DOCSDIR%%/html/introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/iul.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/iur.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/layout.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/layout.html
-%%PORTDOCS%%%%DOCSDIR%%/html/license.html
-%%PORTDOCS%%%%DOCSDIR%%/html/line.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/menu.css
-%%PORTDOCS%%%%DOCSDIR%%/html/menu.html
-%%PORTDOCS%%%%DOCSDIR%%/html/messages.html
-%%PORTDOCS%%%%DOCSDIR%%/html/mouse.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/news.html
-%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
-%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/opengl_logo.png
-%%PORTDOCS%%%%DOCSDIR%%/html/oul.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/oul_grey.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/our.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/page.css
-%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.html
-%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.png
-%%PORTDOCS%%%%DOCSDIR%%/html/printdialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/progress.png
-%%PORTDOCS%%%%DOCSDIR%%/html/projects.html
-%%PORTDOCS%%%%DOCSDIR%%/html/references.html
-%%PORTDOCS%%%%DOCSDIR%%/html/registry.html
-%%PORTDOCS%%%%DOCSDIR%%/html/replacedialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/rex.html
-%%PORTDOCS%%%%DOCSDIR%%/html/rezound_thumb.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/scenegraphnavigator.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/screenshots.html
-%%PORTDOCS%%%%DOCSDIR%%/html/scribble.png
-%%PORTDOCS%%%%DOCSDIR%%/html/scriptolutions.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/searchdialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
-%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
-%%PORTDOCS%%%%DOCSDIR%%/html/slingerzbutton1.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/ss1.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss1_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss2.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss2_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss3.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss3_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
-%%PORTDOCS%%%%DOCSDIR%%/html/table.png
-%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/top.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/vorhour2_small.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/widget.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/widgets.html
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-libraries.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-linkoutput.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-postbuild.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-preprocessor.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-project.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32-tooloptions.png
-%%PORTDOCS%%%%DOCSDIR%%/html/win32.html
-%%PORTDOCS%%%%DOCSDIR%%/html/window.html
-%%PORTDOCS%%%%DOCSDIR%%/html/wintextedit.png
-%%PORTDOCS%%%%DOCSDIR%%/html/xfe.png
-%%PORTDOCS%%%%DOCSDIR%%/html/xfe_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/xml.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/fox-%%MAJORVER%%/chart
-@dirrm include/fox-%%MAJORVER%%