aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gdl
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gdl')
-rw-r--r--x11-toolkits/gdl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index 1759cd802e55..598507ea2ae6 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -20,7 +20,12 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -Ee \
+ 's|-D[^[:space:]_]+_DISABLE_DEPRECATED||g'
+
.include <bsd.port.mk>