aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gnustep-gui/Makefile')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index e505dc5f8d5e..a9918cdfbf8b 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -10,7 +10,7 @@ PORTNAME= gnustep-gui
PORTVERSION= 0.20.0
.else
PORTVERSION= 0.17.1
-PORTREVISION= 2
+PORTREVISION= 3
.endif
CATEGORIES= x11-toolkits gnustep
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
@@ -21,7 +21,7 @@ COMMENT= GNUstep GUI library
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
.if defined(WITH_GNUSTEP_DEVEL)
LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
@@ -56,6 +56,8 @@ MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
BREAKS_IF_PEDANTIC= yes
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
+ADDITIONAL_INCLUDE_DIRS+= -I${LOCALBASE}/include/libpng15
+
.if defined(WITH_GNUSTEP_DEVEL)
EXTRA_PATCHES+= ${FILESDIR}/AudioOutputSink.m.patch
.endif
@@ -93,6 +95,9 @@ PLIST_SUB+= WITH_ASPELL=""
PLIST_SUB+= WITH_ASPELL="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s|libpng/png.h|png.h|" ${WRKSRC}/configure
+
pre-configure:
.for file in config.guess config.sub install-sh
@${CP} ${GNUSTEP_PREFIX}/System/Library/Makefiles/${file} ${WRKSRC}