aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk-sharp20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk-sharp20/Makefile')
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
new file mode 100644
index 000000000000..19d77b9766a1
--- /dev/null
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gtk-sharp
+# Date created: 2003-01-01
+# Whom: Juli Mallett
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-sharp
+PORTVERSION= 0.6.0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= jmallett
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+LIB_DEPENDS= gnomedb-2:${PORTSDIR}/databases/libgnomedb \
+ gnomeui-2:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gphoto2.2:${PORTSDIR}/graphics/gphoto2
+
+# XXX Should conditionalise all the different parts of gtk# maybe.
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+MAKEFILE= makefile
+
+.include <bsd.port.mk>