aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk20/Makefile')
-rw-r--r--x11-toolkits/gtk20/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index ede6012e5f76..cb0896554cc6 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -3,12 +3,13 @@
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.209 2010/11/15 21:17:48 kwm Exp $
+# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.224 2011/06/16 17:36:39 kwm Exp $
#
+# Remember to update graphics/gtk-update-icon-cache too.
PORTNAME= gtk
-PORTVERSION= 2.22.1
-PORTREVISION?= 1
+PORTVERSION= 2.24.5
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
@@ -22,11 +23,11 @@ DISTNAME= gtk+-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Gimp Toolkit for X11 GUI (current stable version)
+COMMENT= Gimp Toolkit for X11 GUI (previous stable version)
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_BZIP2= yes
+USE_XZ= yes
LATEST_LINK= gtk20
.if !defined(REFERENCE_PORT)
@@ -40,16 +41,16 @@ USE_PERL5_BUILD=yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack atk pango gdkpixbuf2 ltverhack
+USE_GNOME= gnomehack atk pango gdkpixbuf2 ltverhack gtk-update-icon-cache
USE_GETTEXT= yes
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
-CONFIGURE_ARGS= --enable-static --with-xinput=yes --with-libjasper
+CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= gtk-query-immodules-2.0.1 gtk-update-icon-cache.1
+MAN1= gtk-query-immodules-2.0.1
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug=yes
@@ -57,7 +58,7 @@ CONFIGURE_ARGS+= --enable-debug=yes
OPTIONS= CUPS "Enable cups printing support" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
@@ -77,6 +78,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|file,cups|file,cups,lpr|' \
${WRKSRC}/gtk/Makefile.in
+pre-configure:
+.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
+ @${ECHO_CMD} "${PKGNAME}: Needs cairo build with X11 support."
+ @${FALSE}
+.endif
+
pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
@@ -89,6 +96,6 @@ post-install:
${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/docs/reference/gtk/|} \
${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif