aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile11
-rw-r--r--x11-toolkits/gtk20/distinfo4
-rw-r--r--x11-toolkits/gtk20/files/patch-ad23
-rw-r--r--x11-toolkits/gtk20/files/patch-ag19
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in22
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_Makefile.in17
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkentry.c13
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c20
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkicontheme.c26
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c16
-rw-r--r--x11-toolkits/gtk20/pkg-plist38
11 files changed, 107 insertions, 102 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 83c017845e56..71a27f969595 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= gtk
-PORTVERSION= 2.4.14
-PORTREVISION= 2
+PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.4,} \
- ftp://ftp.gtk.org/pub/gtk/v2.4/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.6,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.6/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
- ftp://ftp.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
DISTNAME= gtk+-${PORTVERSION}
@@ -39,7 +39,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
USE_BZIP2= yes
LATEST_LINK= gtk20
USE_X_PREFIX= yes
-USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
USE_PERL5= yes
diff --git a/x11-toolkits/gtk20/distinfo b/x11-toolkits/gtk20/distinfo
index e025356fddef..1e943cceaa24 100644
--- a/x11-toolkits/gtk20/distinfo
+++ b/x11-toolkits/gtk20/distinfo
@@ -1,4 +1,4 @@
-MD5 (gnome2/gtk+-2.4.14.tar.bz2) = 10470d574933460809e4ac488e579e26
-SIZE (gnome2/gtk+-2.4.14.tar.bz2) = 9641695
+MD5 (gnome2/gtk+-2.6.4.tar.bz2) = 4749fce7b082b784a71a076aa586dc25
+SIZE (gnome2/gtk+-2.6.4.tar.bz2) = 11222426
MD5 (gnome2/gtk+-2.4.0-menushadow.patch) = 5dde5c5af8f25d282c365663a7256b5c
SIZE (gnome2/gtk+-2.4.0-menushadow.patch) = 15603
diff --git a/x11-toolkits/gtk20/files/patch-ad b/x11-toolkits/gtk20/files/patch-ad
deleted file mode 100644
index 59fee01c4973..000000000000
--- a/x11-toolkits/gtk20/files/patch-ad
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- gtk/gtkrc.c.orig Thu Dec 13 21:51:18 2001
-+++ gtk/gtkrc.c Fri Jan 18 11:14:14 2002
-@@ -336,7 +336,7 @@
- if (im_module_file)
- result = g_strdup (im_module_file);
- else
-- result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules", NULL);
-+ result = g_build_filename (GTK_DATA_PREFIX, "etc", "gtk-2.0", "gtk.immodules", NULL);
- }
-
- return result;
-@@ -418,7 +418,7 @@
- }
- else
- {
-- str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc", NULL);
-+ str = g_build_filename (GTK_SYSCONFDIR, "gtk", NULL);
-
- gtk_rc_add_default_file (str);
- g_free (str);
diff --git a/x11-toolkits/gtk20/files/patch-ag b/x11-toolkits/gtk20/files/patch-ag
deleted file mode 100644
index b34d2b3f24b6..000000000000
--- a/x11-toolkits/gtk20/files/patch-ag
+++ /dev/null
@@ -1,19 +0,0 @@
---- gtk/Makefile.in.orig Fri Oct 24 21:45:12 2003
-+++ gtk/Makefile.in Fri Oct 24 21:46:49 2003
-@@ -301,7 +301,7 @@
- -DGTK_LIBDIR=\"$(libdir)\" \
- -DGTK_DATADIR=\"$(datadir)\" \
- -DGTK_DATA_PREFIX=\"$(prefix)\" \
-- -DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
-+ -DGTK_SYSCONFDIR=\"$(datadir)/themes/Default/gtk-2.0\" \
- -DGTK_VERSION=\"$(GTK_VERSION)\" \
- -DGTK_BINARY_VERSION=\"$(GTK_BINARY_VERSION)\" \
- -DGTK_HOST=\"$(host)\" \
-@@ -856,6 +856,7 @@
- TEST_DEPS = $(DEPS) gtk.immodules
-
- LDADDS = \
-+ $(GLIB_LIBS) \
- $(gtktargetlib) \
- $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
- $(top_builddir)/gdk/$(gdktargetlib)
diff --git a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in
index c2cb10b5478c..1bedfdf55f2c 100644
--- a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in
+++ b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_Makefile.in
@@ -1,13 +1,15 @@
---- gdk-pixbuf/Makefile.in.orig Thu Nov 20 15:39:55 2003
-+++ gdk-pixbuf/Makefile.in Thu Nov 20 15:40:17 2003
-@@ -517,7 +517,9 @@
+--- gdk-pixbuf/Makefile.in.orig Wed Mar 2 15:56:36 2005
++++ gdk-pixbuf/Makefile.in Wed Mar 2 15:57:08 2005
+@@ -519,10 +519,10 @@
+ bin_PROGRAMS = gdk-pixbuf-csource gdk-pixbuf-query-loaders
+ gdk_pixbuf_csource_SOURCES = gdk-pixbuf-csource.c
+-gdk_pixbuf_csource_LDADD = $(LDADDS)
++gdk_pixbuf_csource_LDADD = $(LDADDS) $(GLIB_LIBS)
- AM_CPPFLAGS = "-DPIXBUF_LIBDIR=\"$(loaderdir)\"" "-DBUILT_MODULES_DIR=\"$(srcdir)/.libs\""
--LDADDS = libgdk_pixbuf-$(GTK_API_VERSION).la
-+LDADDS = \
-+ $(GLIB_LIBS) \
-+ libgdk_pixbuf-$(GTK_API_VERSION).la
+ gdk_pixbuf_query_loaders_DEPENDENCIES = $(DEPS)
+-gdk_pixbuf_query_loaders_LDADD = $(LDADDS)
++gdk_pixbuf_query_loaders_LDADD = $(LDADDS) $(GLIB_LIBS)
+
+ gdk_pixbuf_query_loaders_SOURCES = queryloaders.c
- noinst_PROGRAMS = test-gdk-pixbuf
- test_gdk_pixbuf_LDADD = $(LDADDS)
diff --git a/x11-toolkits/gtk20/files/patch-gtk_Makefile.in b/x11-toolkits/gtk20/files/patch-gtk_Makefile.in
new file mode 100644
index 000000000000..44589795f769
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_Makefile.in
@@ -0,0 +1,17 @@
+--- gtk/Makefile.in.orig Wed Mar 2 15:57:44 2005
++++ gtk/Makefile.in Wed Mar 2 15:58:22 2005
+@@ -887,12 +887,12 @@
+ bin_PROGRAMS = gtk-query-immodules-2.0 gtk-update-icon-cache
+
+ gtk_query_immodules_2_0_DEPENDENCIES = $(DEPS)
+-gtk_query_immodules_2_0_LDADD = $(LDADDS)
++gtk_query_immodules_2_0_LDADD = $(LDADDS) $(GLIB_LIBS)
+
+ gtk_query_immodules_2_0_SOURCES = queryimmodules.c
+
+ gtk_update_icon_cache_DEPENDENCIES = $(DEPS)
+-gtk_update_icon_cache_LDADD = $(LDADDS)
++gtk_update_icon_cache_LDADD = $(LDADDS) $(GLIB_LIBS)
+
+ gtk_update_icon_cache_SOURCES = updateiconcache.c
+ subdir = gtk
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c b/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c
new file mode 100644
index 000000000000..e725de399cff
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_gtkentry.c
@@ -0,0 +1,13 @@
+--- gtk/gtkentry.c.orig Wed Aug 25 12:44:23 2004
++++ gtk/gtkentry.c Wed Aug 25 12:44:52 2004
+@@ -1670,8 +1670,9 @@
+ event->x + entry->scroll_offset, event->y))
+ {
+ GdkDragContext *context;
++ guint actions;
+ GtkTargetList *target_list = gtk_target_list_new (NULL, 0);
+- guint actions = entry->editable ? GDK_ACTION_COPY | GDK_ACTION_MOVE : GDK_ACTION_COPY;
++ actions = entry->editable ? GDK_ACTION_COPY | GDK_ACTION_MOVE : GDK_ACTION_COPY;
+
+ gtk_target_list_add_text_targets (target_list);
+
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c b/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c
new file mode 100644
index 000000000000..d393bd3dfa8d
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_gtkiconcache.c
@@ -0,0 +1,20 @@
+--- gtk/gtkiconcache.c.orig Sun Dec 12 16:09:13 2004
++++ gtk/gtkiconcache.c Thu Dec 16 17:09:23 2004
+@@ -21,6 +21,8 @@
+ #include "gtkdebug.h"
+ #include "gtkiconcache.h"
+ #include <glib/gstdio.h>
++#include <sys/types.h>
++#include <sys/stat.h>
+
+ #ifdef HAVE_MMAP
+ #include <sys/mman.h>
+@@ -29,8 +31,6 @@
+ #include <windows.h>
+ #include <io.h>
+ #endif
+-#include <sys/types.h>
+-#include <sys/stat.h>
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkicontheme.c b/x11-toolkits/gtk20/files/patch-gtk_gtkicontheme.c
deleted file mode 100644
index 07bb57a6d022..000000000000
--- a/x11-toolkits/gtk20/files/patch-gtk_gtkicontheme.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- gtk/gtkicontheme.c.orig Thu Jan 29 16:53:42 2004
-+++ gtk/gtkicontheme.c Thu Jan 29 16:54:56 2004
-@@ -526,7 +526,7 @@
-
- priv->custom_theme = FALSE;
- priv->current_theme = g_strdup (DEFAULT_THEME_NAME);
-- priv->search_path = g_new (char *, 5);
-+ priv->search_path = g_new (char *, 7);
-
-
- priv->search_path[0] = g_build_filename (g_get_home_dir (),
-@@ -534,9 +534,11 @@
- NULL);
- priv->search_path[1] = g_build_filename (GTK_DATADIR, "pixmaps", NULL);
- priv->search_path[2] = g_build_filename (GTK_DATADIR, "icons", NULL);
-- priv->search_path[3] = g_strdup ("/usr/share/icons");
-- priv->search_path[4] = g_strdup ("/usr/share/pixmaps");
-- priv->search_path_len = 5;
-+ priv->search_path[3] = g_build_filename (GTK_DATADIR, "gnome", "pixmaps", NULL);
-+ priv->search_path[4] = g_build_filename (GTK_DATADIR, "gnome", "icons", NULL);
-+ priv->search_path[5] = g_strdup ("/usr/share/icons");
-+ priv->search_path[6] = g_strdup ("/usr/share/pixmaps");
-+ priv->search_path_len = 7;
-
- priv->themes_valid = FALSE;
- priv->themes = NULL;
diff --git a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
index 76c5eea6c35b..b39aaedd07b5 100644
--- a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
+++ b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
@@ -1,11 +1,11 @@
---- gtk/xdgmime/xdgmime.c.orig Wed Jun 23 20:19:43 2004
-+++ gtk/xdgmime/xdgmime.c Wed Jun 23 20:19:56 2004
-@@ -98,7 +98,7 @@
+--- gtk/xdgmime/xdgmime.c.orig Mon Nov 8 22:25:27 2004
++++ gtk/xdgmime/xdgmime.c Sat Nov 13 10:27:22 2004
+@@ -204,7 +204,7 @@
- xdg_data_dirs = getenv ("XDG_DATA_DIRS");
- if (xdg_data_dirs == NULL)
-- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
- ptr = xdg_data_dirs;
+ ptr = xdg_data_dirs;
diff --git a/x11-toolkits/gtk20/pkg-plist b/x11-toolkits/gtk20/pkg-plist
index 7e4a1740997d..77127e3a5c4b 100644
--- a/x11-toolkits/gtk20/pkg-plist
+++ b/x11-toolkits/gtk20/pkg-plist
@@ -2,19 +2,23 @@ bin/gdk-pixbuf-csource
bin/gdk-pixbuf-query-loaders
bin/gtk-demo
bin/gtk-query-immodules-2.0
+bin/gtk-update-icon-cache
etc/gtk-2.0/gdk-pixbuf.loaders
etc/gtk-2.0/gtk.immodules
include/gtk-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
include/gtk-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-animation.h
+include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-core.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-enum-types.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-features.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-io.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-loader.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-marshal.h
+include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-transform.h
include/gtk-2.0/gdk-pixbuf/gdk-pixbuf.h
include/gtk-2.0/gdk-pixbuf/gdk-pixdata.h
include/gtk-2.0/gdk/gdk.h
+include/gtk-2.0/gdk/gdkalias.h
include/gtk-2.0/gdk/gdkcolor.h
include/gtk-2.0/gdk/gdkcursor.h
include/gtk-2.0/gdk/gdkdisplay.h
@@ -45,7 +49,10 @@ include/gtk-2.0/gdk/gdkvisual.h
include/gtk-2.0/gdk/gdkwindow.h
include/gtk-2.0/gdk/gdkx.h
include/gtk-2.0/gdkconfig.h
+include/gtk-2.0/gtk/gtkcellview.h
+include/gtk-2.0/gtk/gtkiconview.h
include/gtk-2.0/gtk/gtk.h
+include/gtk-2.0/gtk/gtkaboutdialog.h
include/gtk-2.0/gtk/gtkaccelgroup.h
include/gtk-2.0/gtk/gtkaccellabel.h
include/gtk-2.0/gtk/gtkaccelmap.h
@@ -65,7 +72,9 @@ include/gtk-2.0/gtk/gtkcalendar.h
include/gtk-2.0/gtk/gtkcelleditable.h
include/gtk-2.0/gtk/gtkcelllayout.h
include/gtk-2.0/gtk/gtkcellrenderer.h
+include/gtk-2.0/gtk/gtkcellrenderercombo.h
include/gtk-2.0/gtk/gtkcellrendererpixbuf.h
+include/gtk-2.0/gtk/gtkcellrendererprogress.h
include/gtk-2.0/gtk/gtkcellrenderertext.h
include/gtk-2.0/gtk/gtkcellrenderertoggle.h
include/gtk-2.0/gtk/gtkcheckbutton.h
@@ -92,6 +101,7 @@ include/gtk-2.0/gtk/gtkenums.h
include/gtk-2.0/gtk/gtkeventbox.h
include/gtk-2.0/gtk/gtkexpander.h
include/gtk-2.0/gtk/gtkfilechooser.h
+include/gtk-2.0/gtk/gtkfilechooserbutton.h
include/gtk-2.0/gtk/gtkfilechooserdialog.h
include/gtk-2.0/gtk/gtkfilechooserwidget.h
include/gtk-2.0/gtk/gtkfilefilter.h
@@ -134,8 +144,10 @@ include/gtk-2.0/gtk/gtkmenu.h
include/gtk-2.0/gtk/gtkmenubar.h
include/gtk-2.0/gtk/gtkmenuitem.h
include/gtk-2.0/gtk/gtkmenushell.h
+include/gtk-2.0/gtk/gtkmenutoolbutton.h
include/gtk-2.0/gtk/gtkmessagedialog.h
include/gtk-2.0/gtk/gtkmisc.h
+include/gtk-2.0/gtk/gtkmodules.h
include/gtk-2.0/gtk/gtknotebook.h
include/gtk-2.0/gtk/gtkobject.h
include/gtk-2.0/gtk/gtkoldeditable.h
@@ -214,6 +226,7 @@ include/gtk-2.0/gtk/gtkvscrollbar.h
include/gtk-2.0/gtk/gtkvseparator.h
include/gtk-2.0/gtk/gtkwidget.h
include/gtk-2.0/gtk/gtkwindow.h
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libpixmap.so
lib/gtk-2.0/%%GTK_VERSION%%/immodules/im-am-et.so
lib/gtk-2.0/%%GTK_VERSION%%/immodules/im-cedilla.so
lib/gtk-2.0/%%GTK_VERSION%%/immodules/im-cyrillic-translit.so
@@ -240,16 +253,16 @@ lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xbm.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.so
lib/libgdk-x11-2.0.a
lib/libgdk-x11-2.0.so
-lib/libgdk-x11-2.0.so.400
+lib/libgdk-x11-2.0.so.600
lib/libgdk_pixbuf-2.0.a
lib/libgdk_pixbuf-2.0.so
-lib/libgdk_pixbuf-2.0.so.400
+lib/libgdk_pixbuf-2.0.so.600
lib/libgdk_pixbuf_xlib-2.0.a
lib/libgdk_pixbuf_xlib-2.0.so
-lib/libgdk_pixbuf_xlib-2.0.so.400
+lib/libgdk_pixbuf_xlib-2.0.so.600
lib/libgtk-x11-2.0.a
lib/libgtk-x11-2.0.so
-lib/libgtk-x11-2.0.so.400
+lib/libgtk-x11-2.0.so.600
libdata/pkgconfig/gdk-2.0.pc
libdata/pkgconfig/gdk-pixbuf-2.0.pc
libdata/pkgconfig/gdk-pixbuf-xlib-2.0.pc
@@ -263,6 +276,7 @@ share/gtk-2.0/demo/appwindow.c
share/gtk-2.0/demo/background.jpg
share/gtk-2.0/demo/button_box.c
share/gtk-2.0/demo/changedisplay.c
+share/gtk-2.0/demo/clipboard.c
share/gtk-2.0/demo/colorsel.c
share/gtk-2.0/demo/dialog.c
share/gtk-2.0/demo/drawingarea.c
@@ -273,12 +287,15 @@ share/gtk-2.0/demo/floppybuddy.gif
share/gtk-2.0/demo/gnome-applets.png
share/gtk-2.0/demo/gnome-calendar.png
share/gtk-2.0/demo/gnome-foot.png
+share/gtk-2.0/demo/gnome-fs-directory.png
+share/gtk-2.0/demo/gnome-fs-regular.png
share/gtk-2.0/demo/gnome-gimp.png
share/gtk-2.0/demo/gnome-gmush.png
share/gtk-2.0/demo/gnome-gsame.png
share/gtk-2.0/demo/gnu-keys.png
share/gtk-2.0/demo/gtk-logo-rgb.gif
share/gtk-2.0/demo/hypertext.c
+share/gtk-2.0/demo/iconview.c
share/gtk-2.0/demo/images.c
share/gtk-2.0/demo/list_store.c
share/gtk-2.0/demo/menus.c
@@ -286,6 +303,7 @@ share/gtk-2.0/demo/panes.c
share/gtk-2.0/demo/pixbufs.c
share/gtk-2.0/demo/sizegroup.c
share/gtk-2.0/demo/stock_browser.c
+share/gtk-2.0/demo/rotated_text.c
share/gtk-2.0/demo/textview.c
share/gtk-2.0/demo/tree_store.c
share/gtk-2.0/demo/ui_manager.c
@@ -293,8 +311,6 @@ share/locale/af/LC_MESSAGES/gtk20-properties.mo
share/locale/af/LC_MESSAGES/gtk20.mo
share/locale/am/LC_MESSAGES/gtk20-properties.mo
share/locale/am/LC_MESSAGES/gtk20.mo
-share/locale/ang/LC_MESSAGES/gtk20-properties.mo
-share/locale/ang/LC_MESSAGES/gtk20.mo
share/locale/ar/LC_MESSAGES/gtk20-properties.mo
share/locale/ar/LC_MESSAGES/gtk20.mo
share/locale/az/LC_MESSAGES/gtk20-properties.mo
@@ -407,6 +423,8 @@ share/locale/ro/LC_MESSAGES/gtk20-properties.mo
share/locale/ro/LC_MESSAGES/gtk20.mo
share/locale/ru/LC_MESSAGES/gtk20-properties.mo
share/locale/ru/LC_MESSAGES/gtk20.mo
+share/locale/rw/LC_MESSAGES/gtk20-properties.mo
+share/locale/rw/LC_MESSAGES/gtk20.mo
share/locale/sk/LC_MESSAGES/gtk20-properties.mo
share/locale/sk/LC_MESSAGES/gtk20.mo
share/locale/sl/LC_MESSAGES/gtk20-properties.mo
@@ -439,6 +457,8 @@ share/locale/vi/LC_MESSAGES/gtk20-properties.mo
share/locale/vi/LC_MESSAGES/gtk20.mo
share/locale/wa/LC_MESSAGES/gtk20-properties.mo
share/locale/wa/LC_MESSAGES/gtk20.mo
+share/locale/xh/LC_MESSAGES/gtk20-properties.mo
+share/locale/xh/LC_MESSAGES/gtk20.mo
share/locale/yi/LC_MESSAGES/gtk20-properties.mo
share/locale/yi/LC_MESSAGES/gtk20.mo
share/locale/zh_CN/LC_MESSAGES/gtk20-properties.mo
@@ -470,8 +490,6 @@ share/themes/Emacs/gtk-2.0-key/gtkrc
@exec /bin/mkdir -p %D/lib/gtk-2.0/%%GTK_VERSION%%/engines
@unexec /bin/rmdir %D/share/themes/Default 2>/dev/null || /usr/bin/true
@unexec /bin/rmdir %D/share/themes 2>/dev/null || /usr/bin/true
-@unexec rmdir %D/share/locale/ang/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/ang 2> /dev/null || true
@unexec rmdir %D/share/locale/az_IR/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/az_IR 2> /dev/null || true
@unexec rmdir %D/share/locale/br/LC_MESSAGES 2> /dev/null || true
@@ -484,9 +502,13 @@ share/themes/Emacs/gtk-2.0-key/gtkrc
@unexec rmdir %D/share/locale/mr 2> /dev/null || true
@unexec rmdir %D/share/locale/nso/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/nso 2> /dev/null || true
+@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/rw 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije 2> /dev/null || true
@unexec rmdir %D/share/locale/uz@Latn/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/uz@Latn 2> /dev/null || true
@unexec rmdir %D/share/locale/yi/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/yi 2> /dev/null || true
+@unexec rmdir %D/share/locale/xh/LC_MESSAGES/ 2> /dev/null || true
+@unexec rmdir %D/share/locale/xh 2> /dev/null || true