aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index d2d89ba15bb0..ecd7cbca9423 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -4,8 +4,8 @@
# adwaita-icon-theme, gnome-themes-standard and mate-themes
PORTNAME= gtk
-PORTVERSION= 3.18.8
-PORTREVISION?= 4
+PORTVERSION= 3.22.12
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= 3
@@ -25,7 +25,10 @@ PORTSCOUT= ignore:1
PORTSCOUT= limit:1,even
BUILD_DEPENDS+= at-spi2-atk>=0:accessibility/at-spi2-atk
-LIB_DEPENDS= libepoxy.so:graphics/libepoxy
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
RUN_DEPENDS+= hicolor-icon-theme>=0:misc/hicolor-icon-theme \
adwaita-icon-theme>=0:x11-themes/adwaita-icon-theme \
at-spi2-atk>=0:accessibility/at-spi2-atk
@@ -33,20 +36,19 @@ RUN_DEPENDS+= hicolor-icon-theme>=0:misc/hicolor-icon-theme \
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= atk gdkpixbuf2 introspection:build pango
+USE_GNOME= atk cairo gdkpixbuf2 introspection:build pango
#gtk-update-icon-cache
-USES+= gettext gmake gnome libtool pathfix perl5 pkgconfig
+USES+= gettext gmake gnome libtool localbase pathfix perl5 pkgconfig
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
CONFIGURE_ARGS= --enable-x11-backend \
--disable-wayland-backend \
--enable-introspection
-CPPFLAGS+= -I${LOCALBASE}/include -fno-omit-frame-pointer
-LIBS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -fno-omit-frame-pointer
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-LIBVERSION= 0.1800.8
+LIBVERSION= 0.2200.12
PLIST_SUB+= LIBVERSION=${LIBVERSION}
GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
@@ -54,7 +56,7 @@ GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
org.gtk.Settings.Debug.gschema.xml \
org.gtk.Settings.FileChooser.gschema.xml
-OPTIONS_DEFINE= CUPS CLOUDPRINT COLORD DEBUG BROADWAY
+OPTIONS_DEFINE= CUPS CLOUDPRINT COLORD BROADWAY
OPTIONS_DEFAULT=CUPS COLORD BROADWAY
OPTIONS_SUB= yes