aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile33
1 files changed, 10 insertions, 23 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 3001ebcaaaad..014cf40de698 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -3,14 +3,14 @@
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
+# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.80 2005/10/29 22:42:26 mezz Exp $
#
PORTNAME= gtk
-PORTVERSION= 2.6.10
-PORTREVISION= 1
+PORTVERSION= 2.8.6
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.6,} \
- ftp://ftp.gtk.org/pub/gtk/v2.6/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.8,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.8/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
@@ -20,13 +20,6 @@ MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
DISTNAME= gtk+-${PORTVERSION}
DIST_SUBDIR= gnome2
-.if defined(WITH_DROPSHADOW)
-PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}
-PATCH_SITE_SUBDIR= xfce
-PATCHFILES= gtk+-2.4.0-menushadow.patch
-PATCH_DIST_STRIP= -p1
-.endif
-
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gimp Toolkit for X11 GUI (current stable version)
@@ -43,8 +36,8 @@ USE_XPM= yes
USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack atk pango
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack atk pango ltverhack
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -64,9 +57,10 @@ CONFIGURE_ARGS+= --enable-debug=no
.else
.if ${WITH_DEBUG:L} == "yes"
CONFIGURE_ARGS+= --enable-debug=yes
+STRIP=
.else
CONFIGURE_ARGS+= --enable-debug=minimum
-CFLAGS+= -g
+CFLAGS+= -g
.endif
STRIP=
.endif
@@ -84,15 +78,6 @@ CFLAGS+= -mno-sse2
.endif
pre-everything::
-.if !defined(WITH_DROPSHADOW)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with experimental menu dropshadow patch,"
- @${ECHO_MSG} "hit Ctrl-C right now and use make \"WITH_DROPSHADOW=yes\""
- @${ECHO_MSG} "NOTE: This option is not supported by the FreeBSD GNOME Team."
- @${ECHO_MSG} "If the patch does not work or causes the build to fail, just"
- @${ECHO_MSG} "stop using the patch; we will not further debug it."
- @${ECHO_MSG}
-.endif
.if !defined(WITH_DEBUG)
@${ECHO_MSG}
@${ECHO_MSG} "Enable or disable debugging with the following knob"
@@ -115,6 +100,8 @@ pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
+ -@${FIND} ${PREFIX}/share/icons -type d -depth 1 -exec \
+ ${PREFIX}/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null
@${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
@${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines