aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile109
1 files changed, 0 insertions, 109 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
deleted file mode 100644
index fdb4eebdafb9..000000000000
--- a/x11-toolkits/gtk30/Makefile
+++ /dev/null
@@ -1,109 +0,0 @@
-# New ports collection makefile for: gtk13
-# Date Created: 28 Sep 1997
-# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gtk
-PORTVERSION= 2.6.9
-CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.6,} \
- ftp://ftp.gtk.org/pub/gtk/v2.6/ \
- ftp://ftp.gimp.org/pub/%SUBDIR%/ \
- ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
- http://www.ameth.org/gimp/%SUBDIR%/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
-MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
-DISTNAME= gtk+-${PORTVERSION}
-DIST_SUBDIR= gnome2
-
-.if defined(WITH_DROPSHADOW)
-PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}
-PATCH_SITE_SUBDIR= xfce
-PATCHFILES= gtk+-2.4.0-menushadow.patch
-PATCH_DIST_STRIP= -p1
-.endif
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Gimp Toolkit for X11 GUI (current stable version)
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
- ${X11BASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-
-USE_BZIP2= yes
-LATEST_LINK= gtk20
-USE_X_PREFIX= yes
-USE_XPM= yes
-USE_REINPLACE= yes
-USE_PERL5= yes
-INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack atk pango
-CONFIGURE_ARGS= --enable-static --with-xinput=yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
- -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-GTK_VERSION= 2.4.0
-PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
-
-# Setting WITH_DEBUG=yes effectively adds -g to $CFLAGS
-# unless doing so would clobber a preexisting $CFLAGS.
-# Setting to yes also causes debugging into to be spat out
-# on the command-line.
-# Set to minimum if you want to send in a backtrace; set
-# to yes if you want to know what gtk thinks it's doing.
-.if defined(WITH_DEBUG)
-.if ${WITH_DEBUG:L} == "no"
-CONFIGURE_ARGS+= --enable-debug=no
-.else
-.if ${WITH_DEBUG:L} == "yes"
-CONFIGURE_ARGS+= --enable-debug=yes
-.else
-CONFIGURE_ARGS+= --enable-debug=minimum
-CFLAGS+= -g
-.endif
-STRIP=
-.endif
-.endif
-
-pre-everything::
-.if !defined(WITH_DROPSHADOW)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with experimental menu dropshadow patch,"
- @${ECHO_MSG} "hit Ctrl-C right now and use make \"WITH_DROPSHADOW=yes\""
- @${ECHO_MSG} "NOTE: This option is not supported by the FreeBSD GNOME Team."
- @${ECHO_MSG} "If the patch does not work or causes the build to fail, just"
- @${ECHO_MSG} "stop using the patch; we will not further debug it."
- @${ECHO_MSG}
-.endif
-.if !defined(WITH_DEBUG)
- @${ECHO_MSG}
- @${ECHO_MSG} "Enable or disable debugging with the following knob"
- @${ECHO_MSG} "WITH_DEBUG=[no|minimum|yes]"
- @${ECHO_MSG}
- @${ECHO_MSG} "Default is minimum"
- @${ECHO_MSG}
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${GREP} -l lgmodule | \
- ${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
- @${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/gtk/xdgmime/xdgmime.c
-
-pre-build:
- @${RM} -rf ${WRKSRC}/docs/gtk.info*
-
-post-install:
- @${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
- @${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines
-
-.include <bsd.port.mk>