aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
deleted file mode 100644
index edebf8982175..000000000000
--- a/x11-toolkits/gtk30/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: gtk13
-# Date Created: 28 Sep 1997
-# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gtk
-PORTVERSION= 2.4.0
-CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.4,} \
- ftp://ftp.gtk.org/pub/gtk/v2.3/ \
- ftp://ftp.gimp.org/pub/%SUBDIR%/ \
- ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
- http://www.ameth.org/gimp/%SUBDIR%/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
-MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
-DISTNAME= gtk+-${PORTVERSION}
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Gimp Toolkit for X11 GUI (current stable version)
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
- ${X11BASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-
-USE_BZIP2= yes
-LATEST_LINK= gtk20
-USE_X_PREFIX= yes
-USE_XPM= yes
-USE_REINPLACE= yes
-USE_PERL5= yes
-INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-USE_GNOME= gnomehack atk pango
-CONFIGURE_ARGS= --enable-static --with-xinput=yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
- -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-PLIST_SUB= GTK_VERSION="2.4.0"
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${GREP} -l lgmodule | \
- ${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
- @${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- ${WRKSRC}/gtk/xdgmime/xdgmime.c
-
-pre-build:
- @${RM} -rf ${WRKSRC}/docs/gtk.info*
-
-.include <bsd.port.mk>