aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkmm24/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtkmm24/Makefile')
-rw-r--r--x11-toolkits/gtkmm24/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-toolkits/gtkmm24/Makefile b/x11-toolkits/gtkmm24/Makefile
index 8152579b98e0..71002b7abf60 100644
--- a/x11-toolkits/gtkmm24/Makefile
+++ b/x11-toolkits/gtkmm24/Makefile
@@ -36,20 +36,20 @@ CONFIGURE_ARGS= --enable-static=yes \
PLIST_SUB= VERSION="2.4" API_VERSION="2.4"
.if defined(WITH_EXAMPLES)
+CONFIGURE_ARGS+=--enable-examples
PLIST_SUB+= EXAMPLES=""
.else
+CONFIGURE_ARGS+=--disable-examples
PLIST_SUB+= EXAMPLES="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/tests//' \
+ -e '/^SUBDIRS =/s/demos//' \
${WRKSRC}/Makefile.in
-.if !defined(WITH_EXAMPLES)
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
- ${WRKSRC}/Makefile.in
-.endif
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's/^SUBDIRS = /docs//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/docs//' \
+ ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>