aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkmm30/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtkmm30/Makefile')
-rw-r--r--x11-toolkits/gtkmm30/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index b399c51177cc..858def7e8d32 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -25,9 +26,22 @@ LATEST_LINK= gtkmm2
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--without-gnome \
--with-sigc-prefix=${LOCALBASE}
+.if defined(WITH_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-patch:
+.if !defined(WITH_EXAMPLES)
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>