aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkstep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtkstep/Makefile')
-rw-r--r--x11-toolkits/gtkstep/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/gtkstep/Makefile b/x11-toolkits/gtkstep/Makefile
new file mode 100644
index 000000000000..e96f0b01c406
--- /dev/null
+++ b/x11-toolkits/gtkstep/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtkstep
+# Version required: 1.0.6
+# Date Created: 7 nov 98
+# Whom: Gilad Rom
+#
+# $Id$
+#
+
+DISTNAME= gtk+-1.0.6
+PKGNAME= gtkstep-1.0.6
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.0/ \
+ ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.0/ \
+ http://www.ameth.org/gimp/pub/gtk/v1.0/
+
+PATCH_SITES= http://www-info2.informatik.uni-wuerzburg.de/mitarbeiter/ulli/gtkstep/source/
+PATCHFILES= gtkstep-1.0.6-2.patch.gz
+
+MAINTAINER= rom_glsa@ein-hashofet.co.il
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk10
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>