aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtoolkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtoolkit/Makefile')
-rw-r--r--x11-toolkits/gtoolkit/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index 4aea08876414..f3ac638cd158 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -26,6 +26,7 @@ USE_GNUSTEP_INSTALL= yes
GNU_CONFIGURE= yes
LDCONFIG_DIRS= ${LOCALLIBDIR}
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
MAKE_ARGS+= GNUSTEP_SYSTEM_ROOT=${PREFIX}/System
CONFIGURE_ARGS+= --with-gnustep
@@ -33,11 +34,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/GToolKit
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
post-patch:
- @${MV} ${CONFIGURE_WRKSRC}/configure ${CONFIGURE_WRKSRC}/configure.sed
- ${SED} -e 's#gtk-config#gtk12-config#g' \
- ${CONFIGURE_WRKSRC}/configure.sed \
- > ${CONFIGURE_WRKSRC}/configure
- ${CHMOD} +x ${CONFIGURE_WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's#gtk-config#gtk12-config#g' \
+ ${CONFIGURE_WRKSRC}/configure
.include <bsd.port.pre.mk>