aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-gtk2hs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/hs-gtk2hs/Makefile')
-rw-r--r--x11-toolkits/hs-gtk2hs/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-toolkits/hs-gtk2hs/Makefile b/x11-toolkits/hs-gtk2hs/Makefile
index 8fda420d52f1..16be6a063f26 100644
--- a/x11-toolkits/hs-gtk2hs/Makefile
+++ b/x11-toolkits/hs-gtk2hs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtk2hs
-PORTVERSION= 0.9.6
+PORTVERSION= 0.9.7
CATEGORIES= x11-toolkits haskell
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= A GTK2 Binding for Haskell
-BUILD_DEPENDS= ghc-6.2.2:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc-6.2.2:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS= ghc-6.2.2:${PORTSDIR}/lang/ghc \
+ ${X11BASE}/lib/mozilla/libxpcom.so:${PORTSDIR}/www/mozilla
+RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_GNOME= gtk20 libglade2 gtksourceview
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-c2hs=no
+USE_GNOME= gtk20 libglade2 gtksourceview gconf2
+GNU_CONFIGURE= yes
USE_GMAKE= yes
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`