aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-wxc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/hs-wxc/Makefile')
-rw-r--r--x11-toolkits/hs-wxc/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11-toolkits/hs-wxc/Makefile b/x11-toolkits/hs-wxc/Makefile
index 3ab194b0d69b..fa50f2ed6c8e 100644
--- a/x11-toolkits/hs-wxc/Makefile
+++ b/x11-toolkits/hs-wxc/Makefile
@@ -1,16 +1,13 @@
# $FreeBSD$
PORTNAME= wxc
-PORTVERSION= 0.90.0.4
-PORTREVISION= 7
+PORTVERSION= 0.90.1.1
CATEGORIES= x11-toolkits haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= wxHaskell C++ wrapper
-USE_CABAL= wxdirect>=0.90
-
-BROKEN= does not build with any of the supported wx
+USE_CABAL= wxdirect>=0.90.1.0
USES= dos2unix
USE_WX= 3.0
@@ -20,8 +17,15 @@ WX_UNICODE= yes
OPTIONS_EXCLUDE=DOCS
post-patch::
- @${REINPLACE_CMD} 's|"wx-config"|"wxgtk2u-2.9-config"| ; \
- s|/sbin/ldconfig -n|/sbin/ldconfig -m| ' ${WRKSRC}/Setup.hs
+ @${REINPLACE_CMD} 's|"wx-config"|"wxgtk2u-3.0-config"| ; \
+ s|/sbin/ldconfig -n|/sbin/ldconfig -m| ; \
+ s|"2.9"|"3.0"|' \
+ ${WRKSRC}/Setup.hs
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+
+.if ${OSVERSION} >= 900000
+EXTRA_PATCHES+= ${PATCHDIR}/nopatch-wxc.cabal
+.endif
+
.include <bsd.port.mk>