aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/irrlicht/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/irrlicht/Makefile')
-rw-r--r--x11-toolkits/irrlicht/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/x11-toolkits/irrlicht/Makefile b/x11-toolkits/irrlicht/Makefile
index aa78017db6d8..9e21c3cc26c7 100644
--- a/x11-toolkits/irrlicht/Makefile
+++ b/x11-toolkits/irrlicht/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: irrlicht
-# Date created: 19 September 2004
-# Whom: Simon Barner <barner@gmx.de>
-#
+# Created by: Simon Barner <barner@gmx.de>
# $FreeBSD$
-#
PORTNAME= irrlicht
PORTVERSION= 1.7.3
@@ -35,11 +31,10 @@ EXAMPLEDIRS= 01.HelloWorld 02.Quake3Map 03.CustomSceneNode 04.Movement 05.UserIn
11.PerPixelLighting 12.TerrainRendering 13.RenderToTexture 15.LoadIrrFile \
Demo
-OPTIONS= DEBUG "Compile with debugging simbols" off \
- EXAMPLES "Install example files" on \
- JOYSTICK "Support for Linux Joystick" off
+OPTIONS_DEFINE= DEBUG EXAMPLES JOYSTICK
+JOYSTICK_DESC= Support for Linux Joystick
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if (${ARCH} == "amd64") || (${ARCH} == "ia64")
CFLAGS+= -fPIC
@@ -49,18 +44,18 @@ CFLAGS+= -fPIC
BROKEN= Does not compile on sparc64
.endif
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if defined(WITH_JOYSTICK)
+.if ${PORT_OPTIONS:MJOYSTICK}
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
HAVE_JOYSTICK= true
.endif
-.if !defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
MAKE_ENV+= NDEBUG=1
.endif
@@ -87,7 +82,7 @@ do-install:
${PREFIX}/lib && ${LN} -s libIrrlicht.so.${SHARED_LIB_VER} \
${PREFIX}/lib/libIrrlicht.so
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
.for DIRE in ${EXAMPLEDIRS}
${MKDIR} ${EXAMPLESDIR}/${DIRE}
${INSTALL_DATA} ${WRKSRC}/examples/${DIRE}/Makefile \
@@ -103,4 +98,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>