aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgtkeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/libgtkeditor/Makefile')
-rw-r--r--x11-toolkits/libgtkeditor/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11-toolkits/libgtkeditor/Makefile b/x11-toolkits/libgtkeditor/Makefile
index fb76c6e8b6dc..8f91e7a943ed 100644
--- a/x11-toolkits/libgtkeditor/Makefile
+++ b/x11-toolkits/libgtkeditor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgtkeditor
PORTVERSION= 0.1.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/lib//}
@@ -18,7 +18,7 @@ COMMENT= A source code editor widget for GTK+
LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode
-USE_AUTOTOOLS= automake:15:env autoconf:253:env libtool:13:inc
+USE_AUTOTOOLS= automake:15:env autoconf:253:env libtool:15
USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
@@ -37,7 +37,19 @@ pre-configure:
@${RM} ${WRKSRC}/config.guess ${WRKSRC}/config.sub
@${TOUCH} ${WRKSRC}/config.sub
+# Crazy hacking to get around the fact that the tktext subdirectory
+# generates files ending in .lo that libtool 1.5.x is considerably
+# stricter on than libtool 1.3.x
+CRAZY_HACK_FILES= \
+ gtktextlayout.c gtktext.c gtktextdisplay.c gtktextbtree.c \
+ gtktextbuffer.c gtktexttag.c gtktextmark.c gtktexttypes.c \
+ gstring.c gbsearch.c gtktextchild.c gtktexttagtable.c \
+ gtktextiter.c gtktextsegment.c
+
post-configure:
+.for file in ${CRAZY_HACK_FILES}
+ @${LN} -sf tktext-port/${file} ${WRKSRC}/${file}
+.endfor
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/scanner.c
pre-install: