aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libwnck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/libwnck/Makefile')
-rw-r--r--x11-toolkits/libwnck/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
index 65081a5a17ab..dd51b4fd5017 100644
--- a/x11-toolkits/libwnck/Makefile
+++ b/x11-toolkits/libwnck/Makefile
@@ -16,13 +16,19 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library used for writing pagers and taskslists
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 1
+
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
-USE_BZIP2= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 ltverhack
+USE_GNOME= gnomehack gtk20 ltverhack referencehack
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
@@ -31,3 +37,5 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
+
+.endif