aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-gtk2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/linux-f10-gtk2/Makefile')
-rw-r--r--x11-toolkits/linux-f10-gtk2/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/x11-toolkits/linux-f10-gtk2/Makefile b/x11-toolkits/linux-f10-gtk2/Makefile
deleted file mode 100644
index f615ee4fc2d3..000000000000
--- a/x11-toolkits/linux-f10-gtk2/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: linux-gtk2
-# Date created: 2003-11-19
-# Whom: trevor
-#
-# $FreeBSD$
-#
-
-PORTNAME= gtk2
-PORTVERSION= 2.2.1
-PORTREVISION= 1
-CATEGORIES= x11-toolkits linux
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= GTK+ library, version 2.X, i386 Linux binary
-
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
-
-BASEVERSION= 9
-ONLY_FOR_ARCHS= i386
-PLIST= ${WRKDIR}/plist
-RESTRICTED= "binaries under GNU LGPL without accompanying source"
-RPM_SET= gtk2-2.2.1-4.i386.rpm
-
-pre-install:
- ${RM} -f ${PLIST}
-.for ii in gtk.immodules gdk-pixbuf.loaders
- ${ECHO_CMD} etc/gtk-2.0/${ii} >> ${PLIST}
-.endfor
- ${RM} -rf ${WRKSRC}/tmp
- ${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
- ${FIND} * -type f -o -type l >> ${PLIST}; \
- ${FIND} -d * -type d | ${GREP} -E 'locale|gtk|themes' | \
- ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-
-post-install:
- ${INSTALL_DATA} ${FILESDIR}/gtk.immodules ${PREFIX}/etc/gtk-2.0/
- ${TOUCH} ${PREFIX}/etc/gtk-2.0/gdk-pixbuf.loaders
-
-.include "../linux-gtk/Makefile"