aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/php-gtk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/php-gtk/Makefile')
-rw-r--r--x11-toolkits/php-gtk/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/x11-toolkits/php-gtk/Makefile b/x11-toolkits/php-gtk/Makefile
index 320f6841fd3b..12b53f9954cf 100644
--- a/x11-toolkits/php-gtk/Makefile
+++ b/x11-toolkits/php-gtk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php-gtk
PORTVERSION= 0.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= http://gtk.php.net/distributions/ \
http://document-root.de/mirror/php-gtk/
@@ -27,6 +27,8 @@ RUN_DEPENDS= php:${PORTSDIR}/lang/php4-cli
# Don't call autoconf directly, ./buildconf does this
GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= # none
USE_AUTOCONF= no
USE_GMAKE= yes
USE_PERL5_BUILD=yes
@@ -66,7 +68,7 @@ CONFIGURE_ENV= CPPFLAGS="${ENVSCE}"
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
-PIC2FIX= acinclude.m4 aclocal.m4 autom4te.cache configure
+PIC2FIX= acinclude.m4 aclocal.m4 configure
EXAMPLES= combobutton.php fileselection.php gtk.php hello.php list.php \
piemenu.php scribble.php scrollpane.php spaned.php sqpane.php \
@@ -86,7 +88,7 @@ pre-everything::
pre-configure:
@php ${SCRIPTDIR}/memlim.php
@${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
- @(cd ${WRKSRC} && ./buildconf)
+ @(cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ./buildconf)
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor