aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/php-gtk2
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/php-gtk2')
-rw-r--r--x11-toolkits/php-gtk2/Makefile27
-rw-r--r--x11-toolkits/php-gtk2/distinfo2
-rw-r--r--x11-toolkits/php-gtk2/files/patch-ext_combobutton_combobutton.defs10
-rw-r--r--x11-toolkits/php-gtk2/pkg-message4
-rw-r--r--x11-toolkits/php-gtk2/pkg-plist30
5 files changed, 28 insertions, 45 deletions
diff --git a/x11-toolkits/php-gtk2/Makefile b/x11-toolkits/php-gtk2/Makefile
index 91166d93df7a..d5080b381e66 100644
--- a/x11-toolkits/php-gtk2/Makefile
+++ b/x11-toolkits/php-gtk2/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php-gtk
-PORTVERSION= 0.5.2
-PORTREVISION= 3
+PORTVERSION= 1.0.0
+PORTREVISION= 0
CATEGORIES= x11-toolkits
MASTER_SITES= http://gtk.php.net/distributions/ \
http://document-root.de/mirror/php-gtk/
@@ -15,22 +15,11 @@ MASTER_SITES= http://gtk.php.net/distributions/ \
MAINTAINER= kiesel@schlund.de
COMMENT= An extension to use gtk in PHP-applications
-BROKEN= "Conflicting dependencies: php4-cli and php4; will be removed after Feb 2"
-
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
-# Port does only build with automake-1.4 and
-# automake-1.5 installed - what a mess
-BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
- automake14:${PORTSDIR}/devel/automake14 \
- autoconf:${PORTSDIR}/devel/autoconf \
- autoconf213:${PORTSDIR}/devel/autoconf213 \
- php:${PORTSDIR}/lang/php4-cli
-
# Don't call autoconf directly, ./buildconf does this
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
+WANT_AUTOMAKE_VER= 15
+WANT_AUTOCONF_VER= 253
LIBTOOLFILES= # none
WANT_PHP_CLI= yes
USE_PHPIZE= yes
@@ -38,6 +27,10 @@ USE_AUTOCONF= no
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOME= gtk12
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
# Fix environment for self contained extensions
ENVSCE= -DHAVE_PHP_GTK=1 -DCOMPILE_DL_PHP_GTK=1 \
@@ -74,14 +67,14 @@ PLIST_SUB+= GDKPIXBUF="@comment "
USE_GNOME+= gtkhtml
CONFIGURE_ARGS+= --enable-gtkhtml
ENVSCE+= -DHAVE_HTML=1 -I${X11BASE}/include/gal-1.0 # -DPHP_GTK_COMPILE_DL_GTKHTML=1 -DGTKHTML_HAVE_GCONF=1 -I${X11BASE}/include/gal-1.0
-PLIST_SUB+= GTKHTML=""
+PLIST_SUB+= GTKHTML=""
.else
PLIST_SUB+= GTKHTML="@comment "
.endif
PLIST_SUB+= PHPEXTDIR="${PHP_EXT_DIR}"
-CONFIGURE_ENV= CPPFLAGS="${ENVSCE}"
+CONFIGURE_ENV= CPPFLAGS="${ENVSCE}"
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
diff --git a/x11-toolkits/php-gtk2/distinfo b/x11-toolkits/php-gtk2/distinfo
index f528a20ebae4..12baef3e0479 100644
--- a/x11-toolkits/php-gtk2/distinfo
+++ b/x11-toolkits/php-gtk2/distinfo
@@ -1 +1 @@
-MD5 (php-gtk-0.5.2.tar.gz) = 91e18da45272b5b084e90201f95dfefa
+MD5 (php-gtk-1.0.0.tar.gz) = 38d9d124f0478e2bf4fd059ea58df0f3
diff --git a/x11-toolkits/php-gtk2/files/patch-ext_combobutton_combobutton.defs b/x11-toolkits/php-gtk2/files/patch-ext_combobutton_combobutton.defs
deleted file mode 100644
index 676496dbba92..000000000000
--- a/x11-toolkits/php-gtk2/files/patch-ext_combobutton_combobutton.defs
+++ /dev/null
@@ -1,10 +0,0 @@
---- ext/combobutton/combobutton.defs.orig Mon Sep 23 04:28:29 2002
-+++ ext/combobutton/combobutton.defs Tue Dec 10 22:53:10 2002
-@@ -1,6 +1,6 @@
- ;; -*- scheme -*-
- ; object definitions ...
--(object Combonutton
-+(object ComboButton
- (in-module Gtk)
- (parent Button (Gtk))
- (c-name GtkCombobutton)
diff --git a/x11-toolkits/php-gtk2/pkg-message b/x11-toolkits/php-gtk2/pkg-message
index 8d06011e8c96..d63588fbbc56 100644
--- a/x11-toolkits/php-gtk2/pkg-message
+++ b/x11-toolkits/php-gtk2/pkg-message
@@ -1,7 +1,7 @@
The port has now been installed. Be sure to adjust the config-file
-in e.g. /usr/local/etc/php.gtk/php.ini.
+in e.g. ${PREFIX}/etc/php.gtk/php.ini.
Eventually, you must set the correct 'extension_dir'-path in php.ini.
For convenience put something like
-"alias gtkphp='php -c /usr/local/etc/php.gtk/'"
+"alias gtkphp='php -c ${PREFIX}/etc/php.gtk/'"
in your .profile.
diff --git a/x11-toolkits/php-gtk2/pkg-plist b/x11-toolkits/php-gtk2/pkg-plist
index 002c9280a427..353fc944b26e 100644
--- a/x11-toolkits/php-gtk2/pkg-plist
+++ b/x11-toolkits/php-gtk2/pkg-plist
@@ -1,17 +1,17 @@
etc/php.gtk/php.ini-dist
-%%PHPEXTDIR%%/php_gtk.so
-share/examples/php-gtk/combobutton.php
-share/examples/php-gtk/fileselection.php
-share/examples/php-gtk/gtk.php
-share/examples/php-gtk/hello.php
-share/examples/php-gtk/list.php
-share/examples/php-gtk/piemenu.php
-share/examples/php-gtk/scribble.php
-share/examples/php-gtk/scrollpane.php
-share/examples/php-gtk/spaned.php
-share/examples/php-gtk/sqpane.php
-share/examples/php-gtk/testgtkrc
-share/examples/php-gtk/testgtkrc2
-share/examples/php-gtk/window.xpm
-@dirrm share/examples/php-gtk
+lib/php/%%PHPEXTDIR%%/php_gtk.so
+%%EXAMPLESDIR%%/combobutton.php
+%%EXAMPLESDIR%%/fileselection.php
+%%EXAMPLESDIR%%/gtk.php
+%%EXAMPLESDIR%%/hello.php
+%%EXAMPLESDIR%%/list.php
+%%EXAMPLESDIR%%/piemenu.php
+%%EXAMPLESDIR%%/scribble.php
+%%EXAMPLESDIR%%/scrollpane.php
+%%EXAMPLESDIR%%/spaned.php
+%%EXAMPLESDIR%%/sqpane.php
+%%EXAMPLESDIR%%/testgtkrc
+%%EXAMPLESDIR%%/testgtkrc2
+%%EXAMPLESDIR%%/window.xpm
+@dirrm %%EXAMPLESDIR%%
@dirrm etc/php.gtk