aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-anygui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-anygui/Makefile')
-rw-r--r--x11-toolkits/py-anygui/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-toolkits/py-anygui/Makefile b/x11-toolkits/py-anygui/Makefile
new file mode 100644
index 000000000000..9c22d7e0769e
--- /dev/null
+++ b/x11-toolkits/py-anygui/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-anygui
+# Date created: 29 October 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= anygui
+PORTVERSION= 0.1.a3
+CATEGORIES= x11-toolkits python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C|\.([^.]*)$|\1|}
+
+MAINTAINER= wjv@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+
+USE_PYTHON= yes
+PYTHON_SETUP= ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @ cd ${WRKSRC} && ${PYTHON_SETUP} build
+
+do-install:
+ @ cd ${WRKSRC} && ${PYTHON_SETUP} install -c -O1 --prefix=${PREFIX}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for docfile in CHANGELOG KNOWN_BUGS README MAINTAINERS TODO doc/*
+ @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>