aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gnome-desktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-gnome-desktop/Makefile')
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
new file mode 100644
index 000000000000..9aeb67dc21a7
--- /dev/null
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: py-gnome-desktop
+# Date created: 20 January 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-toolkits/py-gnome-desktop/Makefile,v 1.39 2006/03/12 23:43:07 marcus Exp $
+#
+
+PORTNAME= gnome
+PORTVERSION= 2.14.0
+CATEGORIES= x11-toolkits python gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/..$//}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -desktop
+DISTNAME= gnome-python-desktop-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A set of Python bindings used by modules in the GNOME Desktop
+
+LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop2 \
+ totem-plparser.2:${PORTSDIR}/multimedia/totem-gstreamer \
+ gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack libgnomeprintui gnomepanel \
+ gtksourceview libwnck nautiluscdburner pygnome2 metacity
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+EG_SRC_DIR= ${WRKSRC}/examples
+EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/py-gnome-desktop
+.else
+DOCSDIR= ${WRKSRC}/share/doc/py-gnome-desktop
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${FIND} ${WRKSRC}/docs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|^HTML_DIR =.*|HTML_DIR = ${DOCSDIR}|g'
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EG_DST_DIR}
+ ${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
+.endif
+
+.include <bsd.port.post.mk>