aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt4-gui
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt4-gui')
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile7
-rw-r--r--x11-toolkits/py-qt4-gui/distinfo6
-rw-r--r--x11-toolkits/py-qt4-gui/pkg-plist3
3 files changed, 11 insertions, 5 deletions
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index 1a29bf0e844e..3dfd395181b8 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -6,7 +6,6 @@
PORTNAME= gui
PORTVERSION= ${PYQT4_VERSION}
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
@@ -22,7 +21,7 @@ RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-cor
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
USE_QT_VER= 4
-QT_COMPONENTS= gui imageformats inputmethods iconengines qmake_build
+QT_COMPONENTS= gui imageformats inputmethods iconengines qmake_build moc_build
OPTIONS= API "Install QtGui API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
@@ -66,6 +65,10 @@ PLIST_SUB+= SIP=""
ARGS+= --trace
.endif
+.if ${ARCH} == "sparc64" && ${OSVERSION} >= 700000
+BROKEN= Does not compile on sparc64
+.endif
+
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
${PYTHON_CMD} configure.py ${ARGS}
diff --git a/x11-toolkits/py-qt4-gui/distinfo b/x11-toolkits/py-qt4-gui/distinfo
index 886226b81fb2..a312fab4a870 100644
--- a/x11-toolkits/py-qt4-gui/distinfo
+++ b/x11-toolkits/py-qt4-gui/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4.4.4.tar.gz) = 4bd346d56d10452e47ac71e2cbe04229
-SHA256 (PyQt-x11-gpl-4.4.4.tar.gz) = fc09c13b340078c7995fb2b6450c5b7de8ef9411962d311a1213e773c936509a
-SIZE (PyQt-x11-gpl-4.4.4.tar.gz) = 6982063
+MD5 (PyQt-x11-gpl-4.5.4.tar.gz) = b721266d14c450dd7045025e042819ec
+SHA256 (PyQt-x11-gpl-4.5.4.tar.gz) = b3d06c7bda701055769add93b48103ee35c6fc9a4b00c67599cb426f9efda5a8
+SIZE (PyQt-x11-gpl-4.5.4.tar.gz) = 6970552
diff --git a/x11-toolkits/py-qt4-gui/pkg-plist b/x11-toolkits/py-qt4-gui/pkg-plist
index 3753a886b5d2..743a7234ba0a 100644
--- a/x11-toolkits/py-qt4-gui/pkg-plist
+++ b/x11-toolkits/py-qt4-gui/pkg-plist
@@ -72,6 +72,7 @@
%%SIP%%share/py-sip/QtGui/qimagereader.sip
%%SIP%%share/py-sip/QtGui/qimagewriter.sip
%%SIP%%share/py-sip/QtGui/qinputcontext.sip
+%%SIP%%share/py-sip/QtGui/qinputcontextfactory.sip
%%SIP%%share/py-sip/QtGui/qinputdialog.sip
%%SIP%%share/py-sip/QtGui/qitemdelegate.sip
%%SIP%%share/py-sip/QtGui/qitemeditorfactory.sip
@@ -115,6 +116,7 @@
%%SIP%%share/py-sip/QtGui/qprogressdialog.sip
%%SIP%%share/py-sip/QtGui/qproxymodel.sip
%%SIP%%share/py-sip/QtGui/qpushbutton.sip
+%%SIP%%share/py-sip/QtGui/qpytextobject.sip
%%SIP%%share/py-sip/QtGui/qradiobutton.sip
%%SIP%%share/py-sip/QtGui/qregion.sip
%%SIP%%share/py-sip/QtGui/qrgb.sip
@@ -151,6 +153,7 @@
%%SIP%%share/py-sip/QtGui/qtextcursor.sip
%%SIP%%share/py-sip/QtGui/qtextdocument.sip
%%SIP%%share/py-sip/QtGui/qtextdocumentfragment.sip
+%%SIP%%share/py-sip/QtGui/qtextdocumentwriter.sip
%%SIP%%share/py-sip/QtGui/qtextedit.sip
%%SIP%%share/py-sip/QtGui/qtextformat.sip
%%SIP%%share/py-sip/QtGui/qtextlayout.sip