aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt')
-rw-r--r--x11-toolkits/py-qt/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index 004086c16929..b8d412320286 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_QT_VER= 3
USE_PYTHON= yes
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -35,6 +36,18 @@ do-configure:
-n ${X11BASE}/include -o ${X11BASE}/lib \
-v ${PREFIX}/share/sip)
+.if ${OSVERSION} < 500000
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|static_cast<sipQTable::sipEditMode>(QTable::editMode())|\
+ (sipQTable::sipEditMode) QTable::editMode()|' \
+ ${WRKSRC}/qttable/sipqttableQTable.cpp
+ @${REINPLACE_CMD} -e \
+ 's|static_cast<sipQDataTable::sipEditMode>(QTable::editMode())|\
+ (sipQDataTable::sipEditMode) QTable::editMode()|' \
+ ${WRKSRC}/qtsql/sipqtsqlQDataTable.cpp
+.endif
+
post-install:
@${PYTHON_CMD} -c "import pyqtconfig"
@${PYTHON_CMD} -O -c "import pyqtconfig"