aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-wxPython/Makefile')
-rw-r--r--x11-toolkits/py-wxPython/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/x11-toolkits/py-wxPython/Makefile b/x11-toolkits/py-wxPython/Makefile
index dfd88c154ed4..f994e354d7c4 100644
--- a/x11-toolkits/py-wxPython/Makefile
+++ b/x11-toolkits/py-wxPython/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= py-wxPython
-PORTVERSION= 2.3.1
+PORTNAME= wxPython
+PORTVERSION= 2.3.2.1
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxpython
-DISTNAME= wxPython-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sobomax@FreeBSD.ORG
@@ -44,5 +44,11 @@ do-install:
.for glob in *.py *.pyc
@${INSTALL_DATA} ${WRKSRC}/demo/${glob} ${DEMO_DIR}
.endfor
+.for dir in bitmaps bmp_source data
+ @${MKDIR} ${DEMO_DIR}/${dir}
+.for glob in *
+ @${INSTALL_DATA} ${WRKSRC}/demo/${dir}/${glob} ${DEMO_DIR}/${dir}
+.endfor
+.endfor
.include <bsd.port.mk>