aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython28/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-wxPython28/Makefile')
-rw-r--r--x11-toolkits/py-wxPython28/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index 729cfa086c9b..d147683f508e 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= py-wxPython
-PORTVERSION= 2.2.5
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxpython
@@ -19,12 +18,16 @@ BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
+WX_CONFIG= ${X11BASE}/bin/wx-config
+
USE_GMAKE= yes
USE_NEWGCC= yes
USE_PYTHON= yes
USE_GTK= yes
-MAKE_ENV= WX_CONFIG="${X11BASE}/bin/wx-config"
-SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+MAKE_ENV= WX_CONFIG="${WX_CONFIG}"
+SETUP_ARGS= WX_CONFIG="${WX_CONFIG}"
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py \
+ ${SETUP_ARGS}
DEMO_DIR= ${PYTHON_SITELIBDIR:S/${LOCALBASE}/${PREFIX}/}/wxPython/demo
do-build: