aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython28/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-wxPython28/Makefile')
-rw-r--r--x11-toolkits/py-wxPython28/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
deleted file mode 100644
index 36ad7517a5d9..000000000000
--- a/x11-toolkits/py-wxPython28/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# New ports collection makefile for: wxPython
-# Version required: 2.1.11
-# Date created: September 18, 1999
-# Whom: nectar@FreeBSD.ORG
-#
-# $FreeBSD$
-#
-
-DISTNAME= wxPython-2.1.11
-PKGNAME= py-wxPython-2.1.11
-CATEGORIES= x11-toolkits python
-MASTER_SITES= http://alldunn.com/wxPython/dist/ \
- http://www.nectar.com/distfiles/
-
-MAINTAINER= nectar@FreeBSD.ORG
-
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
-LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
-USE_GMAKE= YES
-USE_NEWGCC= YES
-MAKE_ENV= "LN_S=${LN} -s" "INSTALL_DATA=${INSTALL_DATA}"
-ALL_TARGET= default
-INSTALL_TARGET= install-freebsd
-
-TARGETDIR= ${PREFIX}/lib/python1.5/site-packages/wxPython
-HELPERLIBDIR= ${PREFIX}/lib
-HTMLSRC= ${WRKSRC}/../modules/html
-
-do-configure:
- ${SED} -e "s:%CFLAGS%:${CFLAGS} `gtk12-config --cflags`:" \
- -e "s:%LFLAGS%:`gtk12-config --libs` -L${WRKSRC}:" \
- -e "s:%TARGETDIR%:${TARGETDIR}:" \
- -e "s:%HELPERLIBDIR%:${HELPERLIBDIR}:" \
- -e "s:%CXX%:${CXX}:" -e "s:%WRKSRC%:${WRKSRC}:" \
- ${FILESDIR}/build.local > ${WRKSRC}/../build.local
- cd ${WRKSRC} && ../distrib/build.py
- cd ${HTMLSRC} && ../../distrib/build.py
-
-post-build:
- @(cd ${HTMLSRC}; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-post-install:
- @(cd ${HTMLSRC}; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install)
-
-.include <bsd.port.mk>