aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt23/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qt23/Makefile')
-rw-r--r--x11-toolkits/qt23/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index c6fe54d1abdd..9ff3d5ba1d32 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -61,13 +61,6 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif
@@ -95,17 +88,6 @@ pre-fetch:
qt-pre-configure:
@true
-post-patch:
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-.if !exists(${WRKDIR}/.${PKGNAME}.objprelink_patched)
- @echo "Doing special objprelink patching..."
- cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/objprelink.patch
- ${TOUCH} ${WRKDIR}/.${PKGNAME}.objprelink_patched
-.else
- @echo "Already did the objprelink patching, skipping..."
-.endif
-.endif
-
pre-configure: qt-pre-configure
${PERL} -pi -e "s,gcc,${CC},g; s,g\+\+,${CXX},g; \
s,/usr/X11R6,${X11BASE},g;s,-O2,${CFLAGS},g; \