aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt31/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qt31/Makefile')
-rw-r--r--x11-toolkits/qt31/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index ecad37d0a72c..e7fc891de579 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -34,7 +34,7 @@ USE_X_PREFIX= yes
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
- -system-libmng \
+ -system-libmng -thread \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ARGS+= MAKE="${GMAKE} -j2"
@@ -72,7 +72,7 @@ pre-configure:
-e "s,-pipe -O2,${CXXFLAGS},g" ${CONFIG}.new > ${CONFIG}
.if exists(${X11BASE}/lib/libXft.so) && !defined(NO_AA)
@${CP} ${CONFIG} ${CONFIG}.new
- ${SED} -e "s,= -lXext,= -lXft -lXext,g" -e "s,= -I${X11BASE}/include,= -DQT_XFT -I${X11BASE}/include,g" \
+ ${SED} -e "s,= -lXext,= -lXft -lXext,g" -e "s,QT= -I,QT= -DQT_XFT -I,g" \
${CONFIG}.new > ${CONFIG}
.endif
${CP} ${WRKSRC}/src/Makefile.in ${WRKSRC}/src/Makefile.in.new