aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-quick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qt5-quick/Makefile')
-rw-r--r--x11-toolkits/qt5-quick/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/qt5-quick/Makefile b/x11-toolkits/qt5-quick/Makefile
index 8cf1e89e2ad7..ec0f97a8a930 100644
--- a/x11-toolkits/qt5-quick/Makefile
+++ b/x11-toolkits/qt5-quick/Makefile
@@ -12,7 +12,7 @@ USE_GL= gl
USE_QT5= core gui network qml sql testlib \
widgets xmlpatterns buildtools_build
QT_DIST= declarative
-USES= qmake
+USES= python:build qmake
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
QT_DEFINES= ACCESSIBILITY
@@ -37,4 +37,9 @@ post-configure:
${PRINTF} ".DEFAULT:\n\t@${DO_NADA}" \
> ${CONFIGURE_WRKSRC}/src/qmldevtools/Makefile
+post-patch:
+# qtdeclarative.pro wants to run python, replace that with PYTHON_CMD
+ ${REINPLACE_CMD} '/py_out/s#python#${PYTHON_CMD}#g' \
+ ${WRKSRC}/qtdeclarative.pro
+
.include <bsd.port.mk>