aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qtada/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qtada/Makefile')
-rw-r--r--x11-toolkits/qtada/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-toolkits/qtada/Makefile b/x11-toolkits/qtada/Makefile
new file mode 100644
index 000000000000..eaeda24f74ec
--- /dev/null
+++ b/x11-toolkits/qtada/Makefile
@@ -0,0 +1,42 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= qtada
+PORTVERSION= 3.2.0.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://download.qtada.com/
+DISTNAME= ${PORTNAME}-gpl-3.2.0-20120708-3871
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Ada2005 language bindings to Qt4 framework
+
+BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
+ gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
+ asis>=2011:${PORTSDIR}/lang/asis
+
+USES= ada gmake pkgconfig
+GNU_CONFIGURE= yes
+USE_QT4= corelib gui xml designer sql opengl webkit
+DESTINY= ${WRKDIR}/destino
+MAKE_ENV= DESTDIR=${DESTINY}
+
+#CONFIGURE_ARGS= --with-gtkada=NO
+
+post-install:
+ ${MV} ${DESTINY}${PREFIX}/examples ${DESTINY}${PREFIX}/share/
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+ @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${WRKDIR}/PLIST.all
+ @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
+ ${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
+ -e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \
+ -e '/share\/gprconfig$$/d' -e 's/^/@dirrm /g' \
+ >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gprconfig 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+
+.include <bsd.port.mk>