aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tk84/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tk84/Makefile')
-rw-r--r--x11-toolkits/tk84/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index 1438c5a70a97..7def498b9af8 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -351,6 +351,8 @@ MLINKS= 3DBorder.3 Tk_Alloc3DBorderFromObj.3 \
.endif
+TCL_CHECK!= ( cd ${PORTSDIR}/${PKGCATEGORY}/${TCL84_PORT} && make WRKDIRPREFIX= -V WRKSRC | sed -e 's|/unix$$||' )
+
pre-everything::
@if ${TEST} -e "${NONEXISTENT}"; then ${ECHO_MSG} "=== Aborted, please remove ${NONEXISTENT}"; exit 1; fi
@@ -366,6 +368,7 @@ post-configure:
${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
${WRKSRC}/Makefile
.endif
+ @if ! grep "TCL_SRC_DIR=.\$${WRKDIRPREFIX}${TCL_CHECK}" "${LOCALBASE}/lib/tcl8.4/tclConfig.sh"; then ${ECHO_MSG} "=== Aborted, this configuration is not supported, set PORTSDIR and rebuild tcl84"; exit 1; fi
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/