aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tkstep80/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tkstep80/Makefile')
-rw-r--r--x11-toolkits/tkstep80/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/x11-toolkits/tkstep80/Makefile b/x11-toolkits/tkstep80/Makefile
index 4a70b44a1780..8739836efc68 100644
--- a/x11-toolkits/tkstep80/Makefile
+++ b/x11-toolkits/tkstep80/Makefile
@@ -3,17 +3,16 @@
# Date created: 06 November 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.18 1998/11/25 09:01:22 asami Exp $
+# $Id: Makefile,v 1.19 1998/12/01 03:06:49 asami Exp $
#
-DISTNAME= tk8.0p2
-PKGNAME= tkstep-8.0p2
+DISTNAME= tk8.0.4
+PKGNAME= tkstep-8.0.4
CATEGORIES= x11-toolkits tk80
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_0/
-PATCH_SITES= http://rhein-zeitung.de/~ograf/files/ \
- http://www.uni-koblenz.de/~ograf/files/
-PATCHFILES= tk8.0p2-to-TkStep8.0p2-1.patch.gz
+PATCH_SITES= ftp://touchwood.ee.uts.edu.au/pub/TkSTEP/
+PATCHFILES= tk8.0.4-to-tkstep8.0.4-2.patch.tar.gz
MAINTAINER= tg@FreeBSD.ORG
@@ -24,21 +23,22 @@ LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80 \
FILE_DEPENDS= ${PORTSDIR}/x11-toolkits/tk80
FETCH_BEFORE_ARGS= -b
-PATCH_DIST_ARGS= -p1 -d ${WRKDIR}/tk8.0 -E --quiet
-WRKSRC= ${WRKDIR}/tk8.0/unix
+PATCH_DIST_ARGS= -p1 -d ${WRKDIR}/tk8.0.4 -E --quiet
+WRKSRC= ${WRKDIR}/tk8.0.4/unix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --enable-xpm --enable-step --enable-dnd \
--enable-tiff --with-optimize="${CFLAGS} -I${PREFIX}/include"
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
- @${RM} ${PREFIX}/share/tkstep8.0/demos/*.orig
+ @${RM} ${PREFIX}/lib/tkstep8.0/demos/*.orig
strip ${PREFIX}/bin/wishstep8.0
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/tkstep
- ${INSTALL_DATA} ${WRKDIR}/tk8.0/README.TkStep \
+ ${INSTALL_DATA} ${WRKDIR}/tk8.0.4/README.TkStep \
${PREFIX}/share/doc/tkstep
.endif
+ ${LN} -sf ${PREFIX}/lib/libtkstep80.so.1 ${PREFIX}/lib/libtkstep80.so
${LDCONFIG} -m ${PREFIX}/lib
.if exists(${PORTSDIR}/x11-toolkits/tk80/pkg/INSTALL.wish)
${SH} ${PORTSDIR}/x11-toolkits/tk80/pkg/INSTALL.wish