aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tkstep80/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tkstep80/Makefile')
-rw-r--r--x11-toolkits/tkstep80/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-toolkits/tkstep80/Makefile b/x11-toolkits/tkstep80/Makefile
new file mode 100644
index 000000000000..e218dc7a1ee3
--- /dev/null
+++ b/x11-toolkits/tkstep80/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: TkStep
+# Version required: 8.0
+# Date created: 06 November 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= tk8.0
+PKGNAME= tkstep-8.0
+CATEGORIES= x11 tk80
+MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/
+
+PATCH_SITES= http://rhein-zeitung.de/~ograf/files/
+PATCHFILES= tk8.0-to-TkStep8.0-2.patch.gz
+
+MAINTAINER= tg@FreeBSD.ORG
+
+LIB_DEPENDS= tcl80\\.1\\.:${PORTSDIR}/lang/tcl80 \
+ Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
+ jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg \
+ tiff\\.4\\.:${PORTSDIR}/graphics/tiff34
+
+FETCH_BEFORE_ARGS= -b
+PATCH_DIST_ARGS= -p -d ${WRKDIR} -E --quiet
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-shared --enable-xpm --enable-step --enable-dnd \
+ --enable-tiff --with-optimize="${CFLAGS} -I${PREFIX}/include"
+CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
+
+post-install:
+ @${RM} ${PREFIX}/share/tkstep8.0/demos/*.orig
+ strip ${PREFIX}/bin/wishstep8.0
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/tkstep
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README.TkStep \
+ ${PREFIX}/share/doc/tkstep
+.endif
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+test:
+ cd ${WRKSRC}; make test
+
+.include <bsd.port.mk>