aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tkstep80/files/patch-aa
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/tkstep80/files/patch-aa')
-rw-r--r--x11-toolkits/tkstep80/files/patch-aa37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-toolkits/tkstep80/files/patch-aa b/x11-toolkits/tkstep80/files/patch-aa
new file mode 100644
index 000000000000..c39f29c64f77
--- /dev/null
+++ b/x11-toolkits/tkstep80/files/patch-aa
@@ -0,0 +1,37 @@
+--- configure.orig Fri Aug 15 22:17:52 1997
++++ configure Wed Oct 1 10:50:54 1997
+@@ -662,14 +662,14 @@
+ if test -n "$withval"; then
+ TCL_BIN_DIR=$withval
+ else
+- TCL_BIN_DIR=`cd ../../tcl8.0/unix; pwd`
++ TCL_BIN_DIR=${prefix}/lib/tcl8.0
+ fi
+
+ if test ! -d $TCL_BIN_DIR; then
+ { echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
+ fi
+-if test ! -f $TCL_BIN_DIR/Makefile; then
+- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
++if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
++ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+ fi
+
+ #--------------------------------------------------------------------
+@@ -688,6 +688,8 @@
+ DL_LIBS=$TCL_DL_LIBS
+ LD_FLAGS=$TCL_LD_FLAGS
+
++TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
++
+ LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
+
+ # If Tcl and Tk are installed in different places, adjust the library
+@@ -2271,6 +2273,7 @@
+ s%@SHLIB_VERSION@%$SHLIB_VERSION%g
+ s%@TCL_BIN_DIR@%$TCL_BIN_DIR%g
+ s%@TCL_BUILD_LIB_SPEC@%$TCL_BUILD_LIB_SPEC%g
++s%@TCL_LIB_SPEC@%$TCL_LIB_SPEC%g
+ s%@TCL_SRC_DIR@%$TCL_SRC_DIR%g
+ s%@TCL_VERSION@%$TCL_VERSION%g
+ s%@TK_BUILD_LIB_SPEC@%$TK_BUILD_LIB_SPEC%g