aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/vte3/Makefile')
-rw-r--r--x11-toolkits/vte3/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index 5a30f49eb6a4..cdec5b10cf16 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vte
-PORTVERSION= 0.50.3
+PORTVERSION= 0.52.2
PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
@@ -17,11 +17,12 @@ LICENSE= LGPL21
BUILD_DEPENDS= vapigen:lang/vala \
bash:shells/bash
LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libfribidi.so:converters/fribidi \
libpcre2-8.so:devel/pcre2
PORTSCOUT= limitw:1,even
-USES= compiler:c++0x gettext gmake gnome gperf libtool localbase \
+USES= compiler:c++11-lang gettext gmake gnome gperf libtool localbase \
pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -33,4 +34,10 @@ INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=2.91
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} <= 1100000
+EXTRA_PATCHES= ${FILESDIR}/extra-src_app_app.cc
+.endif
+
.include <bsd.port.mk>