aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/wxd/Makefile')
-rw-r--r--x11-toolkits/wxd/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-toolkits/wxd/Makefile b/x11-toolkits/wxd/Makefile
new file mode 100644
index 000000000000..fcbf16b61922
--- /dev/null
+++ b/x11-toolkits/wxd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: wxd
+# Date created: 29 August 2006
+# Whom: Jona Joachim <walkingshadow@grummel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxd
+PORTVERSION= 0.07
+CATEGORIES= x11-toolkits devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= walkingshadow@grummel.net
+COMMENT= wxWidgets bindings for the D programming language
+
+BUILD_DEPENDS= gdc:${PORTSDIR}/lang/gdc
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_WX= 2.6
+WX_UNICODE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-patch:
+ @${RM} ${WRKSRC}/Makefile
+ @${MV} ${WRKSRC}/GNUmakefile ${WRKSRC}/Makefile
+ @${RM} ${WRKSRC}/wxc/Makefile
+ @${MV} ${WRKSRC}/wxc/GNUmakefile ${WRKSRC}/wxc/Makefile
+ @${RM} ${WRKSRC}/wx/Makefile
+ @${MV} ${WRKSRC}/wx/GNUmakefile ${WRKSRC}/wx/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/Samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= needs FreeBSD 5.x or later
+.endif
+
+.include <bsd.port.post.mk>