aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk28/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/wxgtk28/Makefile')
-rw-r--r--x11-toolkits/wxgtk28/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index e61f53390733..a5be69343ad6 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS+= libpng.so:graphics/png\
libtiff.so:graphics/tiff\
libexpat.so:textproc/expat2
-USES= compiler gmake iconv jpeg pkgconfig tar:bzip2
+USES= compiler:c++11-lang gl gmake iconv jpeg localbase pkgconfig \
+ tar:bzip2
USE_CXXSTD= gnu++98
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
@@ -34,8 +35,6 @@ CONFIGURE_ARGS= --with-libpng=sys\
--disable-backtrace\
--enable-graphics_ctx
CONFIGURE_ENV= X11BASE="${LOCALBASE}"
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2