aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk29/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/wxgtk29/Makefile')
-rw-r--r--x11-toolkits/wxgtk29/Makefile103
1 files changed, 103 insertions, 0 deletions
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
new file mode 100644
index 000000000000..6bb41471d0fd
--- /dev/null
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: wxgtk2-devel
+# Date created: June 27, 2004
+# Whom: fjoe@FreeBSD.ORG
+#
+# $FreeBSD$
+#
+
+PORTNAME= wx
+PORTVERSION= 2.5.2
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wxwindows
+PKGNAMESUFFIX= ${WXGTK_FLAVOR}-devel
+DISTNAME= wxGTK-${PORTVERSION}
+
+MAINTAINER?= fjoe@FreeBSD.org
+COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings (devel version)
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ expat.5:${PORTSDIR}/textproc/expat2
+
+CONFLICTS= wxgtk-*
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libpng=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --with-zlib=sys \
+ --with-expat=sys \
+ --with-opengl \
+ --enable-gtk2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -liconv \
+ -L${X11BASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+PLIST= ${.CURDIR}/pkg-plist
+
+WXGTK_FLAVOR?= gtk2
+
+.if ${WXGTK_FLAVOR} != "gtk2-common"
+RUN_DEPENDS= ${X11BASE}/include/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk2-common-devel
+.endif
+
+.if ${WXGTK_FLAVOR:M*-common} != ""
+NO_BUILD= yes
+INSTALL_TARGET= install-common
+.else
+INSTALLS_SHLIB= yes
+.endif # *-common
+
+.if ${WXGTK_FLAVOR:M*-contrib*} != "" || ${WXGTK_FLAVOR:M*-utils*} != ""
+.if ${WXGTK_FLAVOR:M*-utils*} != ""
+BUILD_WRKSRC= ${WRKSRC}/contrib/utils
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+.else
+BUILD_WRKSRC= ${WRKSRC}/contrib
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+.endif # *-utils*
+
+.if ${WXGTK_FLAVOR} != "gtk2-contrib-common"
+RUN_DEPENDS= ${X11BASE}/include/wx/stc/stc.h:${PORTSDIR}/x11-toolkits/wxgtk2-contrib-common-devel
+
+.if ${WXGTK_FLAVOR:M*-unicode*} != ""
+LIB_DEPENDS+= wx_baseu-2.5.2:${PORTSDIR}/x11-toolkits/wxgtk2-unicode-devel
+.else
+LIB_DEPENDS+= wx_base-2.5.2:${PORTSDIR}/x11-toolkits/wxgtk2-devel
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC}/contrib -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e "s,@CXXFLAGS@,${CFLAGS} `${WXGTK_CONFIG} --cxxflags`," \
+ -e "s,@CFLAGS@,${CFLAGS} `${WXGTK_CONFIG} --cflags`," \
+ -e "s,@CPPFLAGS@,,"
+.endif # !gtk2-contrib-common
+.endif # *-contrib* || *-utils*
+
+.include <bsd.port.pre.mk>
+
+.if ${WXGTK_FLAVOR:M*-unicode*} != ""
+.if ${OSVERSION} < 500000
+IGNORE= Systems prior to FreeBSD 5.0 currently out of support
+.else
+CONFIGURE_ARGS+=--enable-unicode
+.endif
+
+WXGTK_CONFIG= ${X11BASE}/bin/wxgtk2u-2.5-config
+.else
+WXGTK_CONFIG= ${X11BASE}/bin/wxgtk2-2.5-config
+.endif # *-unicode*
+
+.include <bsd.port.post.mk>