aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xclasses/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/xclasses/Makefile')
-rw-r--r--x11-toolkits/xclasses/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-toolkits/xclasses/Makefile b/x11-toolkits/xclasses/Makefile
new file mode 100644
index 000000000000..61d9c6e33d87
--- /dev/null
+++ b/x11-toolkits/xclasses/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xclasses
+# Date created: 2000-10-01
+# Whom: Trevor Johnson <trevor@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xclasses
+PORTVERSION= 1.1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://fsai.fh-trier.de/~schmitzj/Xclasses/arc/
+DISTNAME= Xclasses-public-${PORTVERSION}.src
+
+MAINTAINER= trevor@FreeBSD.org
+
+USE_X_PREFIX= yes
+PLIST_SUB= VERSION="${PORTVERSION}"
+WRKSRC= ${WRKDIR}/xclasses
+
+post-patch:
+ @${PERL} -pi -e "s=X11BASE=${X11BASE}=g" ${WRKSRC}/build \
+ ${WRKSRC}/System/ARules.FreeBSD
+
+do-build:
+ @cd ${WRKSRC} && ${SH} build all
+
+do-install:
+ @cd ${WRKSRC} && ${SH} build install
+ @${INSTALL_SCRIPT} ${WRKSRC}/setenvxc ${PREFIX}/bin
+
+.include <bsd.port.mk>