aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xforms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/xforms/Makefile')
-rw-r--r--x11-toolkits/xforms/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/x11-toolkits/xforms/Makefile b/x11-toolkits/xforms/Makefile
index 9ce5e7d6a1dc..2529bdfaaa20 100644
--- a/x11-toolkits/xforms/Makefile
+++ b/x11-toolkits/xforms/Makefile
@@ -3,15 +3,20 @@
# Date created: 28 March 1997
# Whom: gena
#
-# $Id: Makefile,v 1.22 1998/12/27 18:43:33 dirk Exp $
+# $Id: Makefile,v 1.23 1999/01/07 08:19:54 simokawa Exp $
#
USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "elf"
+.if ${MACHINE_ARCH} == "alpha"
+DISTNAME= bxform-freebsd-alpha
+.else
DISTNAME= bxform-freebsd-elf
-MASTER_SITES= http://bragg.phys.uwm.edu/~zhao/ftp/
+.endif
+MASTER_SITES= http://www.freebsd.org/~steve/distfiles/ \
+ http://bragg.phys.uwm.edu/~zhao/ftp/
PATCHDIR= ${.CURDIR}/patches.elf
.else
DISTNAME= bxform-088
@@ -25,29 +30,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gena@NetVision.net.il
-ONLY_FOR_ARCHS= i386
-
PATCH_STRIP= -p0 -t
WRKSRC= ${WRKDIR}/xforms
MAN1= fdesign.1 fd2ps.1
MAN5= xforms.5
-# XXX: ask the author to include the right soname
-.if ${PORTOBJFORMAT} == "elf"
-.if !exists(/usr/bin/perl5)
-pre-fetch:
- @${ECHO} "Need perl5 to patch soname"
- @${FALSE}
-.endif
-.endif
-
post-install:
-# XXX: ask the author to include the right soname
-.if ${PORTOBJFORMAT} == "elf"
- /usr/bin/perl5 -pe 's/libforms.so.0.88/libxforms.so.0\000\000/' < ${PREFIX}/lib/libxforms.so.0 > ${PREFIX}/lib/libxforms.so.0.tmp
- ${MV} ${PREFIX}/lib/libxforms.so.0.tmp ${PREFIX}/lib/libxforms.so.0
-.endif
- ${LDCONFIG} -m ${PREFIX}/lib
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.if !defined(NOMANCOMPRESS)
@${RM} ${PREFIX}/man/man5/forms.5
@ln -fs xforms.5.gz ${PREFIX}/man/man5/forms.5.gz