aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk2/Makefile3
-rw-r--r--x11-toolkits/fltk2/distinfo6
-rw-r--r--x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h10
3 files changed, 14 insertions, 5 deletions
diff --git a/x11-toolkits/fltk2/Makefile b/x11-toolkits/fltk2/Makefile
index f3984c0b0116..c777053535de 100644
--- a/x11-toolkits/fltk2/Makefile
+++ b/x11-toolkits/fltk2/Makefile
@@ -7,7 +7,6 @@
PORTNAME= fltk
PORTVERSION= 2.0.${SNAPSHOT}
-PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/snapshots
@@ -30,7 +29,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-SNAPSHOT= r6305
+SNAPSHOT= r6671
OPTIONS= FLTK_THREADS "Install with threads support" on \
FLTK_CAIRO "Use cairo as graphics backend" off \
diff --git a/x11-toolkits/fltk2/distinfo b/x11-toolkits/fltk2/distinfo
index e2b367f6ff72..a02798fcc448 100644
--- a/x11-toolkits/fltk2/distinfo
+++ b/x11-toolkits/fltk2/distinfo
@@ -1,3 +1,3 @@
-MD5 (fltk-2.0.x-r6305.tar.bz2) = c9f310b3e248343165e4c235d010eb4b
-SHA256 (fltk-2.0.x-r6305.tar.bz2) = a2833a500387b1104771f0984deabffb0c6b3d1c2c2375169b5c314199ac5095
-SIZE (fltk-2.0.x-r6305.tar.bz2) = 2526774
+MD5 (fltk-2.0.x-r6671.tar.bz2) = 6bcef5fd51eb3bc4dd0702f3ae6da6ba
+SHA256 (fltk-2.0.x-r6671.tar.bz2) = 4c9a67f0d32c05af92bf95d5feec8eb4a8d56bfbfe2cd4364b32009cfd609b54
+SIZE (fltk-2.0.x-r6671.tar.bz2) = 2527397
diff --git a/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h b/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h
new file mode 100644
index 000000000000..ee999dba6e5e
--- /dev/null
+++ b/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h
@@ -0,0 +1,10 @@
+--- fltk/fltk_cairo.h.orig 2009-03-08 14:41:16.000000000 +0100
++++ fltk/fltk_cairo.h 2009-03-08 14:41:47.000000000 +0100
+@@ -35,6 +35,7 @@
+
+ #include <fltk/FL_API.h>
+ #include <cairo.h>
++#include <string.h> /* for memcpy() */
+
+ namespace fltk {
+ extern FL_API cairo_t * cr;