aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/nucleo/Makefile4
-rw-r--r--x11-toolkits/nucleo/files/patch-nucleo_gl_texture_glTexture.cxx13
2 files changed, 14 insertions, 3 deletions
diff --git a/x11-toolkits/nucleo/Makefile b/x11-toolkits/nucleo/Makefile
index 5660f240ef22..8734c38ebde6 100644
--- a/x11-toolkits/nucleo/Makefile
+++ b/x11-toolkits/nucleo/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libexif.so:graphics/libexif \
libfreetype.so:print/freetype2 \
libexpat.so:textproc/expat2
-USES= compiler:c++11-lang gl gmake jpeg libtool localbase:ldflags \
+USES= gl gmake jpeg libtool localbase:ldflags \
pathfix pkgconfig python:run shebangfix tar:bzip2
USE_GL= gl glu
GNU_CONFIGURE= yes
@@ -27,8 +27,6 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
SHEBANG_FILES= docs/MacOSX/nBundle.in
-CXXFLAGS+= -Wno-c++11-narrowing
-
OPTIONS_DEFINE= FFMPEG GD GNUTLS QT4
OPTIONS_RADIO= DNSSD
OPTIONS_RADIO_DNSSD= AVAHI MDNSRESPONDER
diff --git a/x11-toolkits/nucleo/files/patch-nucleo_gl_texture_glTexture.cxx b/x11-toolkits/nucleo/files/patch-nucleo_gl_texture_glTexture.cxx
new file mode 100644
index 000000000000..6367d4cb460b
--- /dev/null
+++ b/x11-toolkits/nucleo/files/patch-nucleo_gl_texture_glTexture.cxx
@@ -0,0 +1,13 @@
+--- nucleo/gl/texture/glTexture.cxx.orig 2009-06-02 09:34:34 UTC
++++ nucleo/gl/texture/glTexture.cxx
+@@ -426,7 +426,9 @@ namespace nucleo {
+ {left, top, 0.0}
+ } ;
+
+- GLdouble texinfo[] = { left, bottom, tWidth, tHeight, 1.0, 1.0 } ;
++ GLdouble texinfo[] = { left, bottom,
++ static_cast<GLdouble>(tWidth), static_cast<GLdouble>(tHeight),
++ 1.0, 1.0 } ;
+ if (tTarget==GL_TEXTURE_2D) {
+ texinfo[4] = t->getTextureWidth() ;
+ texinfo[5] = t->getTextureHeight() ;