aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt30/Makefile4
-rw-r--r--x11-toolkits/qt31/Makefile4
-rw-r--r--x11-toolkits/qt32/Makefile4
-rw-r--r--x11-toolkits/qt33/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index 2aee19e54e48..125d8f1fda57 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -99,6 +99,10 @@ post-patch:
npunix.c npwin.cpp
${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,g++,${CXX},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index 2aee19e54e48..125d8f1fda57 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -99,6 +99,10 @@ post-patch:
npunix.c npwin.cpp
${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,g++,${CXX},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index 2aee19e54e48..125d8f1fda57 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -99,6 +99,10 @@ post-patch:
npunix.c npwin.cpp
${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,g++,${CXX},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 2aee19e54e48..125d8f1fda57 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -99,6 +99,10 @@ post-patch:
npunix.c npwin.cpp
${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,g++,${CXX},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install: