aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Tk-ResizeButton/Makefile26
-rw-r--r--x11-toolkits/p5-Tk-ResizeButton/distinfo2
-rw-r--r--x11-toolkits/p5-Tk-ResizeButton/pkg-descr7
-rw-r--r--x11-toolkits/p5-Tk-ResizeButton/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 9bf17c7f0be0..eb29c8353bb7 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -128,6 +128,7 @@
SUBDIR += p5-Tk-GBARR
SUBDIR += p5-Tk-Getopt
SUBDIR += p5-Tk-HistEntry
+ SUBDIR += p5-Tk-ResizeButton
SUBDIR += p5-Tk-TableMatrix
SUBDIR += p5-qt
SUBDIR += pango
diff --git a/x11-toolkits/p5-Tk-ResizeButton/Makefile b/x11-toolkits/p5-Tk-ResizeButton/Makefile
new file mode 100644
index 000000000000..ad9328e98d7b
--- /dev/null
+++ b/x11-toolkits/p5-Tk-ResizeButton/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Tk-ResizeButton
+# Date created: August 10th 2004
+# Whom: Lubomir Marinov <lubomir_m@abv.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-ResizeButton
+PORTVERSION= 0.01
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tk
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lubomir_m@abv.bg
+COMMENT= A resizeable button to be used in a Tk::HList column header
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${LOCALBASE}/lib/perl5/${PERL_VERSION}
+MAN3= Tk::ResizeButton.3
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Tk-ResizeButton/distinfo b/x11-toolkits/p5-Tk-ResizeButton/distinfo
new file mode 100644
index 000000000000..40770344d8ce
--- /dev/null
+++ b/x11-toolkits/p5-Tk-ResizeButton/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tk-ResizeButton-0.01.tar.gz) = b1c782ec46e3bcb7e52fdd5909645ad2
+SIZE (Tk-ResizeButton-0.01.tar.gz) = 3946
diff --git a/x11-toolkits/p5-Tk-ResizeButton/pkg-descr b/x11-toolkits/p5-Tk-ResizeButton/pkg-descr
new file mode 100644
index 000000000000..76f435fa6ffa
--- /dev/null
+++ b/x11-toolkits/p5-Tk-ResizeButton/pkg-descr
@@ -0,0 +1,7 @@
+The ResizeButton widget provides a resizeable button widget for use
+in an HList column header. When placed in the column header, the
+edge of the widget can be selected and dragged to a new location to
+change the size of the HList column. When resizing the column, a
+column bar will also be placed over the HList indicating the eventual
+size of the HList column. A command can also be bound to the button
+to do things like sorting the column.
diff --git a/x11-toolkits/p5-Tk-ResizeButton/pkg-plist b/x11-toolkits/p5-Tk-ResizeButton/pkg-plist
new file mode 100644
index 000000000000..2ad841f84cb8
--- /dev/null
+++ b/x11-toolkits/p5-Tk-ResizeButton/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Tk/ResizeButton.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/ResizeButton/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/ResizeButton
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tk 2>/dev/null || true